Download issues?

Trying to download Sketchup (any version, would love make '17) but every time I’ve attempted the download I receive an error message and can’t get anywhere. It’s the same error code every time and I’ve tried a variety of things to resolve it. I currently am using Sketchup on the web but the limited tool options and lack of ability to make a cut list is a hinderance.

The error message for those wondering seems to be centered around HRESULT - 2147024770

Any feedback is welcome, I tried subscribing to fix the issue with no results.


Where are you trying to download from?

You should be able to download SU 2017 Make from here:

It was working for me a minute ago.

And Dave’s question is pertinent. This is a link to the official site.

Download All | SketchUp

That’s where I was trying, I’ve tried to download all versions and had the same error message.

I just downloaded 2017 Make from there with no problem. What browser are you using?

Edge, I read the browser shouldn’t cause issues, but I’ll try IE real quick

It shouldn’t make any difference but it may. Try Chrome.

Try Chrome instead of IE which is obsolete.

Where are you? That might make a difference, though as Dave says, the browser shouldn’t for a simple download.

Tried Chrome, no luck, it says the thumbsup.dll fails to register and gives me the error message.
I’m on the east coast, VA

That’s a message you get during installation, so it sounds as if you have succeeded in downloading the installer.

Two suggestions, if that is the case.

  1. Try again to run the installer, and if you didn’t do it last time, R-click and choose ‘Run as administrator’ then when offered the choice, choose Repair.

  2. If that still doesn’t work, search this forum for ‘thumbs up.dll’. I remember the error, but not the solution.

where will I see the option to run repair? I did troubleshoot the run as admin part, but I haven’t been able to find the repair

If it doesn’t appear, it’s possible the original installation didn’t finish.

I’m on a Mac. So can’t easily try it myself.

Try my second suggestion if you have already tried the first.

Did you pay for a Pro subscription? If so you would only download and install the version you subscribed to (2021).

See if the steps that I gave in this post help:

It looks like you just started a 30 day trial of SketchUp, you may as well try to get the 2021 version going. If that does manage to install, but after the trial you would rather use Make 2017, it’s likely to install ok as well. You could install both now, and at least get four weeks in which to see what Pro gives you that Make doesn’t, though Make will also start off with Pro features at first.

I just tried installing Pro 2021 and got the shortcuts on my desktop, but when I went to open SU it gave me error: MSVCP140.dll not found. It said to reinstall the program however I’ve scrubbed and redownloaded and had no luck.

As for searching for c++, I only have the bundled 2015-2019 c++, should I try deleting that and reinstall?

I’d love to download both and compare, but at this point I would just like to make a cut list once.

Re-ran the installer for SU21 with the repair feature, still no luck…
feeling bleak.

I did it!!!
It ended up being the c++, I went to delete it and restart MS but went ahead and repaired it before fully uninstalling and it was fixed in 30 seconds! just signed into Pro and I can’t wait.
I really appreciate all the quick replies and suggestions it really helped to constantly be trying things to fix the issue. Great forum!

1 Like