Download of 32 & 64-bit SketchUpMake.exe not completing

Need advise here. I’ve attempted downloading the above .exe files several times using download managers and not. they stop downloading after 50-95% complete, displaying Error 403. I have Sketchup 8.0 already on the same PC (not sure that’s the problem, but I’m not about to remove it). I do not have a Trimble/Sketchup license, so tech support told me they will not assist.

I download from http://www.sketchup.com/download/all.

Any ideas?

John
W7 pro, 64-bit

It is not the problem. SketchUp versions can be installed side-by-side on the same machine. (I have 5 versions installed on my test machines.)

It is likely your ISP doing what they call “Throttling”. Try to download at off peak hours. … midnight to 5am.


empty the browser cache and disable browser plugins used for filtering as e.g. a security suite/firewall or an ad blocker or a script blocker.

Thank you both for your responses. Following are replies to your suggestions. Anything else you recommend is appreciated.

1] Verizon told me my download speed is “dynamic”, meaning it fluxuates. I see the download speeds vary from 0KB/s to 200Kb/s. Though my download manager allows a set speed, downloads still vary between zero and whatever number I choose. So I am not sure if or how this helps.
2] IE browser cache is emptied and script blocker disabled (from what I’m able to do in IE’s internet options). I have Chrome but read IE is recommended for sketchup download.
3] Windows Firewall is disabled for a few of the attempted downloads. It did not seem to affect speed or achieve a full download of the 121 Mb file.
4] I don’t have an ad blocker that I know of.
5] Verizon has been my ISP for several years over which I have downloaded very large files like Adobe CS (1GB+), flight sims and scenery, without issue.

I’m dispirited by not being able to upgrade Sketchup which has not been a problem to update ever.

download can be done by the browser of your choice, no MS IE req.

Download managers allow to set the max. speed for keeping some bandwith free for other applications/services, configuring a min. speed is not possible because dependend on internet connection and server speed.

If the download speed drops to zero there*s something wrong w/ your internet access/connection… which seems to trigger the #403 Forbidden HTTP status.

If you do have access to another system, you may want try if downloading from there works.

I successfully download the 121MB .exe file after twenty or so failed attempts. As tried before, Chrome was used without a download manager, and I can’t ascribe a reason for why it finally worked.

Thanks to those that responded with suggestions for remedy. I wish I could describe what definitively led to the successful download.

John

What time was it for you locally when the download was successful ?
And what time zone are you in ?

Ie, sometimes it also matters where the source server is, what time of day and what it’s local traffic is like. It’s likely in the San Jose CA area.
Ref: ICANN Lookup

Noon East Coast.

John