Unable to Download SketchUp

I had thought I posted this earlier, but it is not showing up. If this ends up being a duplicate post, I will try to delete it.

Every time I try to download SketchUp 2016, the download is either interrupted or suddenly stops and does not progress. Either way, if I try to resume the download, it says the program cannot be downloaded.
I tried to download on this Windows 10 using Edge (Unknown Version) and Explorer (11), and on Windows 7 using Explorer (Unknown Version), and all had the same problem.

While not denying other possibilities, because this has happened with multiple browsers and Windows versions I’d start with your ISP. Some of them throttle downloads after a certain amount of data. Have you downloaded similar multi-hundred megabyte items before without difficulty?

Well, I got Unity, SketchUp 2013, Audacity, a MIDI sequencer (Anvil Studio), Paint Dot Net, Blender (Which I can’t figure out how to use), and countless other programs all on my Windows 7 laptop. I successfully moved Unity and updated it, moved Audacity, and reinstalled PDN on my new Windows 10 laptop. I recently tried to get Maya, but I had a similar problem to this one in the installing process. So, it’s likely my ISP. BUT, due to where I live, the internet is around 10-20 KB/s, and sometimes drops to around 1 KB/s for unknown reasons, I always assumed internet traffic.

This is only topic you’ve started with the @JoeMiner account, and it contains the only 2 posts (so far) for this account.

(Moving the thread to the Technical Problems category.)

Related threads: