Trouble with Solids Subtract Tool

I’m having a problem using the solids tool to subtract two solid groups. There are two solids in the model and I want to subtract the ‘K’ object from the other solid group. When I do so, it generally works but there are two faces that do not work properly: 1. The right hand side of the ‘K’ and 2.The leftmost portion of the scroll object. Somehow the faces end up getting merged/corrupted??? (Just perform the subtract option on the two objects in the model to see the issue I’m describing.) I’m expecting a simple/clean punchout of one solid group object into the other.

Any idea what is wrong with my model and why it is behaving this way?


Subtract problem.skp (1.2 MB)

Like this?

I expect you are butting heads with the tiny geometry thing. I made the thing getting the piercing into a component and then used “The Dave Method” to do it. Does this go on all four sides?

1 Like

That is exactly what I’m trying to do. Glad to hear the “Dave Method” worked. I need to become a more savvy user and learn how the “Dave method works”! Yes - It does go on all 4 sides, but I was tying to simplify my question in the post.

Good enough. Here I’ve added the other three sides.

Instead of subtracting each time I trimmed away all but one side with a large “cutter” solid and then used Rotate/Copy to make the other three sides from the first.

And the file.

Subtract no problem.skp (2.8 MB)

Thank you very much! I’m not worthy, but I’m willing to learn. :slight_smile: I tried to work with the version you uploaded and it appears it might be a beta or something. When I try to import and save the model, I get strange behavior. Could you please save and re-upload in a native production version of SU Pro, so I can pick up where you left off?

Thanks agan.


1 Like

You’re welcome. I still expect you to do it yourself. :wink:

The file I downloaded seems to have some issues. It reports it is from a newer version of SU than I am using, but there are no updates available for my Pro version. Could you please re-upload a version based on Pro 2021 latest production release.

That’s weird. I’m using 2021. But here’s a 2020 version. See if that works for you.
Subtract no problem.skp (6.2 MB)

Thanks again DaveR. I downloaded the new file and opened it (see caption), but it appears to be missing some of the geometry still. Maybe I need some extension I don’t have installed?



Huh! It’s weird that it works for me with no missing geometry.

Any Ideas what I might try?

How are you going to be using the model?

3D printing the output.

Is it at the correct size now?

Or maybe a better question is how large is the post this thing is to mount on?

It is scaled up for now trying to get the model to congeal. Final Post dimension is 126 x 126 mm

By what factor did you scale it up?

Try this file in your slicer making sure the import units are set to millimeters.
Subtract no problem.stl (2.2 MB)

scaled it by a factor of 20 When I performed the operation it has the same problem. Interestingly, if I cut a single face, the object being cut is no longer a solid. Maybe that is a clue to what is going on. Thanks for the updated model. I’ll try it. I’d really like to understand what I’m doing wrong on this so I can prevent it in the future. Odd, we are getting different results.

Generally when I need to do this sort of thing I scale up by 1000 so I can treat millimeters as meters and I don’t have to do any math related to the scale. Did you try the .stl file in the slicer?

Since .stl files are unitless, I leave the model at meters when I export the file. Then import at millimeters and it’s all cool.

Just found where the issue occurs. My program is doing check validity automatically. When I undo that step, the issue goes away!!!??? What is “check validity” and why would it cause geometry issues???

1 Like