Trouble importing a DXF/DWG file

I am trying to import a very simple shape into Sketchup. I have done this many times in the past but for some reason, this shape either imports w/nothing inside or imports missing part of it. It is almost identical to another file I made but with a slightly different curve, so I am really stumped. See attached. thanks

inner stem.dxf (58.9 KB)

This is what I get.

What are the import units set to?

Nessie is famously elusive.

1 Like

I was able to import it into SU Pro 2020. Here is the result.

inner_stem.skp (37.8 KB)

I had to remember to set the import [Options] to AutoCAD (.dwg, .dxf) first before inner_stem.dxf would show as a valid type to open.

Not sure how your version (Shop) treats .dxf import - sorry, I don’t regularly use any web version.

PS. I see that as usual, DaveR gets there before me!

I finally spotted her. :smiley:


Of course. He uses ESP to foresee incoming. Bit like Tommy.

1 Like

He also types VERY FAST.

Ain’t got no distractions…

Not according to my high school typing teacher who does a 360 in her grave every time I set my index finger on the keyboard. :smiley:

Well, then you are faking it big time. Your replies are usually very quick. Do you dictate into a Voice to Text converter to reply so fast?

I used to think that my wife when younger was the fastest two finger typist in the West. If you are just using two index fingers, you are certainly in her league.

Nessie! Ok, so you all imported it perfectly. So what could be wrong on my end?

Ok, next clue… I opened a new file and it imported just fine, but it won’t import properly into my existing model. I can just copy and paste it I think but still don’t get it.

Good question.

Perhaps one or more of these suggestions?

  • Does Shop do .dxf imports? You mention both .dwg and .dxf in your subject line.
    Were your previous successful imports .dwg instead of .dxf? Would this one import as .dwg (if you have a .dwg version)?
  • look at this forum post - from a couple of years ago, admittedly, but it might still be relevant
    Sketchup Shop how to import dxf

I wonder if the model you are trying to import into has some problems.

Does Shop have what older Make and current Pro versions all have - a Model Info including Statistics/Purge Unused and Fix Problems? Try one or both of those, or try copying and pasting all of your existing model that won’t import your inner_stem.dxf file into a new file, then try the import again.

I just started with a new file and copy/paste yielded same result. Then I imported directly and it imports messed up although differently. I have tried both dxf and dwg and tried checking all boxes on import.

What import units are you using?

I have tried both model units and inches

Try meters and resize it after it’s imported.

done, same result

Got it!! I had an invisible layer on the DXF file. Once I deleted it, it worked like a charm. Sorry, I should have caught that. Thanks again!

1 Like