Trouble importing DXF into SketchUp


#1

Hey guys,

I am having an issue when trying to import a DXF file into SketchUp in such a way that when/if the file has radius corners, it will separate those corners and put them to the side, then i will have to move them over to their appropriate place. It is very annoying and i was wondering if there was a way of fixing this issue. This happens if i use Rhino or Draftsight. I have attached an image to show you a simple shape for reference. Thanks in advance!


#2

How are you importing the DXF into SketchUp? You profile indicates you are using SketchUp Make which doesn’t offer DXF import.


#3

I am using Pro. I must have selected the wrong one. I will change that.


#4

Can you share the DXF file?


#5

Sure.

recon.dxf (163.4 KB)


#6

This is what I get when I import it into SU2018.

What options are you using for import?


#7

Capture


#8

So you aren’t using the native DXF importer? What are you using, then?


#9

This is the program that was installed once the CNC table was brought into my workplace. It has the option to use the native importer, but it just freezes and will not import the file or any file for that matter. We have to convert to a file that the CNC will read and to do so, we use this importer. Could that be the culprit?


#10

I expect it is. Try disabling that extension and use the native importer.


#11

Ok, i will try that. Another interesting note… IOf i save it in Rhino as a SketchUp file then try to import into SketchUp, it will not come in scaled to size. It will be much smaller and I have checked all the settings i could find, but it doesn’t import correctly. It would be much easier to just save as .SKP then import


#12

Why do you have to go through so many programs? If you’re creating the model in Rhino with the intent of going to the CNC software, why are you getting SketchUp in the middle?

What file type is the CNC software looking for? There is some CNC software which will import a SKP file directly.


#13

Are you missing the Option button on the Import dialog?


#14

I know it sounds like extra steps, and it is, but we have to go through SketchUp to convert the files. We use .UC files on our CNC table. The files are specific to the company that produces the CNC. It gets aggravating having to go through different programs, but I am not sure of a workaround at this time.


#15

I don’t see one.


#16

Options


#17

That’s odd. I do not see that on mine. I think its because I am having to use a dxf to uc importer.


#18

Yes … the options dialog is part of SketchUp Pro’s DWG/DXF import system.

BONUS: Side note pertaining correcting geometry scale… if one knows the measurement of one item in the import, one can use the Tape Measure tool to correct the size of geometry.

CD


#19

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.