Increasing dxf quality

Hi All,

Something i find very annoying with sketchup is when importing dxf files with curves into a drawing. It imports terribly and is basically unusable. Apart from having to redraw the shape and maximising the lines on the curve sections ( which is a pain and sometimes not feasible) does any one know a workaround? Cheers Ben

Can you share an example of a dxf file that does not import well?


This is how it should look


this is how it comes out when imported into sketch up

How large is it in SketchUp? Can you share the .dxf file?

bounty new lower logo.dxf (270.6 KB)
Here’s the dxf file

Try importing in LayOut, first. Than export as dwg with ‘export as native dwg/dxf entities’ unchecked and export for SketchUp checked.
Import in SketchUp and resize as needed.

2 Likes

SKP model: bounty new lower logo.skp (318.3 KB)

How did you manage to do that Mihai? This is a problem that happens for me quite alot. Know how to solve it would be amazing!

Thanks. Ill give it a go

It looks to me as if the drawing in the .dxf file is a long way from the origin. What happens if you move it closer to the origin before exporting the .dxf file?

Sorry mike
I don’t understand why to export in layout first.
I’ve tried and it’s not going well.
You have to explain to me

Why is it not possible to save directly from Sketchup as DWG / DXF.

The curves are segments and not polylines.
I always have to redraw too.

It’s not about exporting from SketchUp, but about importing a dxf.
When importing, circle’s and arc’s curvy things are reduced to segments in SketchUp.
Importing in LayOut first will increase that number.

Exporting with these settings:

  • 2 Unchecked Export as native DWG/DXF entities
    to trick the importer when importing in SketchUp!

ImportedDXFviaLayOut.skp (177,4 KB)

2 Likes

The lower left corner is somewhere like 60 units from the origin, and the whole thing is more than 1000 units wide, so it shouldn’t be overly much.

The problem is not arcs and circles. The shapes consist of bezier curves. For some reason the SketchUp importer skips one of the corner points. Converting the splines into standard polylines in AutoCad prior to importing might help, or, if this is from Illustrator or another illustration app, adding segments and straightening before export to DXF might produce a more consistent result.

1 Like

I edited my post!

Thanks so much Mike! that workaround is going to save me so much hassle :slight_smile:

Love this.

1 Like

Wow, that works like a charm!

Thanks Mike.

1 Like