Cannot import DWG files or DXF because not exist in menu "import"?

please i can’t start to work because I get files from CAD ( DWG and DXF ) but my skpro 2021 don’t purpose that kind of files to import? somebody knows why??

The import dialog has a drop down menu where you can choose the file type.

no in mine many types exist but not precisely those!!

Hello / bonjour
Are you sure you are going to file > import (fichier > importer ) and not file > open (fichier > ouvrir) ?
also, do you have sketchup make installed on the same computer ?

Show us a screenshot of what you see.

thanks for helping ! i’m trying to import , not to open file , I don’t have SK make on my computer , I’m opening it with FIREFOX, but it’s little bit difficult for me to understand all the SK softwares !
I’ve just tried to re open SK pro 2021 and choosing Architecture , not simple , and now it purpose the file DWG… !
BUT it doesn’t work because :

Some of the imported geometry is located extremely far from the
original model. If you experience instability on
your SketchUp model, please delete this geometry
in your .dwg / .dxf file and import it again.

Post the DWG file and/or the SketchUp model if you can.
What happens if you Zoom to Extents? Which import unit did you use?(Options button on the Import dialog) Was it the same as used to create the file?
To me the import message looks like nothing might have imported except empty layers. What should be in the file? Was it created using special Autodesk tools like AutoCad Civil or AutoCad Architecture? The special objects must be converted to standard AutoCad objects before they can be understood by other applications.
Just some possibilities

ok thanks : EXT01 plan RDC.dwg (16.0 KB)

and this is same but other type of file :EXT 01 plan RDC.dxf (161.8 KB)

When you import a CAD file its geometry might have been created kilometers away for the origin.
This can cause OpenGL issues because SketchUp expects ‘modest’ distances…
In the import dialog for DWG or DXF there is an Options button.
If you click that there is an option ‘toggle’ to maintain the CAD origin, you can usually have that off and the SketchUp importer will place its geometry near to the SketchUp origin.

Another issue can occur - even if you have done this step - if the CAD file has some rogue geometry kilometers away from the rest similar issues can arise.
In this case you need to ensure that the CAD works is done well and there’s nothing ‘wrong’ with it…

bonjour, vos deux fichiers ont des xref manquantes. voir capture d’écran :

Il faut que la personne qui vous a envoyé le fichier lie la xref au fichier avant de l’enregistrer (clic droit sur la xref, lier - dans autocad) ou qu’elle choisisse d’autres options d’export depuis archiCAD)

As @paul.millet says , the files are empty, there is only a missing XREF. Even if the XREF was present, SketchUp won’t import it unless it is converted into a block (with the xbind command) or exploded first.

thanks to all of you for your help, i’ll try to tell him to send other cad files like you’ve said ; merci !!

1 Like

hello , I’m proud to say that the the files are imported ! with your help and advices :slightly_smiling_face:

this is the reply of the architect who sent me the files :

we used this software during our studies but it is getting old and today we are not working with it for 3D.
We will find out and see if, by passing our files through Autocad, that solves the problem (we are working with Archicad).
While waiting for a final internal test, we exported the file by simplifying the content and maintaining only the lines: tell us if it works or if the problem is elsewhere.

Some remarks that could be useful:

  • the scale can be changed when extracting the files, so there is a graphic scale at the bottom left of plans whose width is 1m;
  • the superimposition of the levels is not perfect, we are in old and everything is a bit “twisted” including the vertical walls.
1 Like

good to know !

In addition, as far as I can remember, archicad is able to export to .skp file directly. Why don’t they do that ?

"Dans la Fenêtre 3D, choisissez la commande Fichier > Enregistrer sous pour enregistrer le modèle ARCHICAD au format .skp.

Dans le dialogue Options exportation SketchUp qui apparaît :

•Cochez les éléments et les calques à exporter, ces options permettant d’optimiser la taille du modèle exporté

•Choisissez le format de Sketchup dans lequel vous voulez enregistrer.

Les coordonnées d’emplacement globales du fichier SketchUp obtenu correspondront aux coordonnées de l’emplacement du projet ARCHICAD.

La marque dans le fichier SketchUp (le point de référence de l’emplacement) correspond à l’origine du projet ARCHICAD."

source : Formats modèle/3D enregistrés par ARCHICAD

Archicad can export SketchUp files directly from its 3D window (Save as…)