Error when Importing dwg

I am trying to import a 3d autocad file that seems fine when I open it in ACAD. It was exported into autocad from a different drawing program but when I import into sketchup it simply doesn’t show up. I’ve never had this issue before. Thought someone might be able to help.
thanks!

Please clarify what you mean by “simply doesn’t show up”. Do you mean that the import seems to run without error, but there is nothing visible in the view?

If so, you may be victim of one or more of the very common problems when importing dwg files.

First, if you didn’t specify the units to match the file, SketchUp may have mis-scaled your model. It might be either too large or too small to see. Try zoom-extents and see whether anything shows up. You could also try ctrl-A to select everything. If you can find the geometry, you can use the scale tool or tape measure to restore it to the right scale.

Second, ACAD is notorious for putting the origin far distant from the model contents. If you didn’t uncheck “preserve model origin” during import, you may find that your contents are somewhere far removed from the view. Again, if you can find the contents by the previous, group them and move them to the model origin by activating the move tool and typing [0,0,0] into the VCB (note: some locales may require [0;0;0]. Also, the [] are part of what you must type.

Third, the previous two issues can combine to induce “clipping plane” issues in which OpenGL chops some or all of your model in the view. If you can get the contents to the right scale and located at the origin, the clipping plane problems will usually go away - though sometimes SketchUp seems to “get stuck” with a plane and the only answer is to save the model, close SketchUp, and restart it.

Is your import unit set to the right value?
Does the import status window say anything about entities ignored?
SketchUp cannot import all AutoCad objects. things like

  • xrefs
  • custom objects (like AutoCad Architecture walls)
  • proxies (entities from missing applications)
  • 3D solids or surfaces generated from splines
    do not import. Special objects should be converted to standard objects in the application that made them. Surfaces or splined solids should be converted to meshes.

Can you post a DWG that you cannot import?

Anssi

CAD.dwg (187.0 KB)

it fails here due to it being splines…

you need to convert them first…

maybe you can add spline import to the feature request list…

or here’s one I prepared easier…

CAD_splines.skp (1022.7 KB)

john

Your file was in the AutoCad 2018 format. SketchUp cannot import that. I saved it into the older version (2013…2017) with Autodesk’s free DWG TrueView and it imported OK. The importer in SketchUp 2018 handles splines much better than older versions (my earlier post was from when v.2015 was the newest)
cad.skp (1.0 MB)

Hi, I have the same problem but cant fix it !

I’m trying for the first time to import a dwg file, but get the same issue as above (the import runs Ok, the model size inceases, but nothing shows up)

I tried a sample file from the net, that loaded and was visible
It doesn’t appear to be a scaling or origin issue (I cant find any geometry anywhere)
I dont know the autocad version, as the file has come from a supplier of a supplier (a topographic land survey, I expected contours)

File attached, any help really gratefully received!
Thanks
Ben

CEBIA_LAND.dwg (466.7 KB)

Here is what I got. The contours came in perfectly. Some parts of the DWG were ignored as they were created by some AutoCad mapping add-on.

Your problem was probably related to scaling and origin. The contents of the file are located more than 4000 kilometers from the origin point, assuming that the units used are meters. I deselected the “Preserve drawing origin” option so the file came in centered on the model origin. You cannot work in SketchUp with geometry placed to the original location as inside the file.

cebia_land.skp (1.4 MB)

i have no problem importing the file into SU 2019 Pro.

Some entity types are ignored.


The import comes in quite small - very much smaller than the human figure.

If I delete the figure, and Zoom All, I see this, (relatively speaking - all of 10") quite a way above the origin. Click on the image below to enlarge it, and see assorted stray lines near or on the red-green plane:

Purged, I get this SU file, saved back to SU 2017…

CEBIA_LAND.skp (815.7 KB)

It seems a large file for what it contains. You might want to find a plugin to smooth the contour lines and reduce the edge count, before doing anything else with it.

And if it IS terrain contours, as it appears, the scale is wildly too small. Some of the larger edge segments are below 1/16th of an inch

If you use Make 2017 as your profile indicates, you can’t import DWG files - AFAIK it’s a Pro only feature

Thanks Anssi & John, its good to know the file contains what I need

John, I am using a plugin (SimLab DWG importer) to address the Make 2017 issue. It worked file with a test DWG, so I thought that wasnt the issue, maybe it is as…

(Anssi) …that plugin doesn’t give me an origin or scale option. Sadly I cant open your skp in my SU version 17.2 (2017), any chance of saving a backdated version for me to try?

Thanks again
Ben

Anssi may well back save to v2017 for you (he’s generous), but in case you need to open other later version files, see the Eneroth3 plugin on the Extension Warehouse called Open Later Versions. It works up to SU2019, and she may well update it when later versions come out from v2020 onwards

Too much said, but here’s the file in the v.2016 format.
cebia_land.skp (1.2 MB)

You guys are great, thanks so much for for your help.
Anssi - That file opens and it it looks like the contours I need, I’ll have a play
John - I’ll take a look at that plugin, it looks really useful

I’ve also contacted the file originator and asked for a copy of the file with an origin somewhere within the geometry drawn, it will be interesting to see if that fixes the problem when using my other plugin

Thanks again
Ben

See if there’s an option to uncheck ‘preserve drawing origin’ in your software. There is in the SU Pro import, and I think I must have set it accidentally on your file, because it came in at the SU origin for me, unlike for Anssi.

You also probably used Millimeters as the import unit. With the “preserve origin” option enabled the contours would still land somewhere more than 4 kilometers away.

Hello, I have exactly the same issue with my auto cad file that I would like to import to sketch. It is a 3D terrain but Sketchup recognise it as a zombie even though I tried to convert it to both mesh and solid. Could anyone help me with that? Thank you!
teren.dwg (513.5 KB)

It seems to work here in SketchUp 2020. If that’s a road, it comes in about the right size (about 4m) when importing with inches as the unit.


teren.skp (4.9 MB)

1 Like

Wow, you’re a magician! My sketch 2018 shows this message and afterwards “import failed”. Thank you! The thing is I need a bigger area to convert from dwg to sketchup, could you help me with that as well? Otherwise, I don’t know where the problem really is :confused: Could that really be that I use an older version? Of course I am saving the file in auto cad 2013 though. The units are metres but that should be easily scaled. teren-all.dwg (4.2 MB)

terrain-SU2017.skp (5.4 MB)