Imported .dwg not visible, reports entities imported successful

I´ve using Sketchup for years now, and been using the same workflow. I draw a plan on draft sight, import it to Sketchup as a dwg (versión 2010), and use it to trace and develop a 3d model of it. Today I tried it and the result was an empty outline selection box. ¿Can anyone help me?

Can you share the DWG file that is causing you problems?

Of course.MarquesL7Mz29SKP2010.dwg (1.0 MB)

Your DWG file has a bit of geometry miles away - top-left.
Thus the imported geometry is foobar when it comes to ‘extents’.
I imported in meters [ since I had no alternative measurements to guess at ! ]
Selected ALL and zoomed-extents.
Saw little ‘bit’ in the distance.
I selected the rest using a ‘fence’ and the remote part was no longer included,
So I selected the remote part only and deleted it.
Then I selected the rest and zoomed-extents - I see what you’d expect ? …

Your CAD file is sloppy…


TIG beat me to it but I think that solves your problem. Not a problem with SketchUp but rather a problem in your original file.

1 Like

Thank you. It solved it indeed.

I also have a similar problem to this. I imported my cad file to sketchup but a blank rectangle only shows up when I use zoom extent. What can I do to make my model appear??Drawing1 - Copy - Copy.dwg (98.3 KB)

Is this what you are expecting to see?

If you pay attention to the message that appears after import, you can see that the geometry is located at a great distance from the origin.
Screenshot - 10_25_2020 , 11_00_40 AM

drawing1.skp (553.8 KB)

What version of SketchUp are you using? Your profile indicates a version that does not exist.

I’m using 2019. I’ve already found it but it keeps disappearing as I zoom further. How can I prevent it from doing that when I zoom.

It’s sort of a GIGO thing. You should really fix the .dwg first.

Here it is as a 2019 file. drawing1.skp (553.8 KB)

Please fix your forum profile so it is correct.

Can you help me with this one instead cause the first one has jagged lines caused I messed with the cad file. Thanks in advance mate :grin:
Drawing1 - Copy - Copy.dwg (100.9 KB)

Fix the origin in the .dwg first. Don’t make me work with another bad file.

Sorry but that’s the best I can do with the cad file. please help me I just keeps disappearing as I zoom in

That’s the best?


Here you go.
drawing1.skp (548.8 KB)

Fix your profile now.

yes cause I’m not really familiar with doing models like that on cad, it’s a first for me. thank you very much for your help :pleading_face:

how did you do that??? can you teach me?? hahaha

It was just a matter of getting rid of some of the garbage you left in the .dwg and moving the remainder to the origin where it belongs. You should upgrade to SketchUp 2020 so you have Invert Selection. That comes in handy for this sort of thing.

1 Like

ahhhhh okay. thanks a lot. i’m really sorry for being bad at cad hahaha. may you have a great day sir :smile:

The issue with the dwg is that it has two portions that are located an immense distance apart compared to their own sizes. There is a line made up of 102 edges at one extreme and the drawing of the face (another 9986 edges) at the opposite extreme. Even with “preserve origin” turned off, SketchUp must import in a way that covers both of these. Because they are so far apart, that makes them too small to see.

The simplest way to fix this would be to clean up the dwg in CAD to eliminate that line, as it has no useful value. Then import into SketchUp with preserve origin turned off so that the drawing of the face comes in at SketchUp’s origin. The only remaining issue will then be to choose the right units in the import vs the model so that the drawing has a sensible size.

It can also be repaired in SketchUp after import, but that’s trickier because the extent makes SketchUp very “twitchy” and it’s awkward to select and move things you can’t see!