"Some imported geometry is extremely far from the model origin" error while trying to import .dwg file

Hi All,

I’m trying to import one of the file to .dwg file to SU but keeps getting the following error.


Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

Layers:		154
Blocks:		56
3d Faces:		2175
Arcs:		484
Circles:		50
Ellipses:		5
Inserts:		725
Lines:		2660
2d Poly-lines:	595
2d Solids:		2
Splines:		4

AutoCAD Entities Simplified:

Coords out of range:	16927

AutoCAD Entities Ignored:

AttDefs:			1
Leaders:			3
M-Texts:			28
Anonymous Blocks:		206
Zombies and Others:	9

Tried on different PCs with different versions but I keep getting the same error.

Can someone please guide through the solution for the issue?


What version of SketchUp are you actually using? Your profile says you are using 2021 Free (web). The free web version doesn’t have .dwg import capability.

If you are using SketchUp Pro, have you unticked the box for Preserve Origin in the import options. Otr have you tried fixing the .dwg file? Sharing the .dwg file would help us help you.

Please update your profile with the correct information.

Hi Dave,

Sorry about that. Might have mistakenly selected the wrong version there.

The attached file is the .dwg file that I’m trying to import to the SU.

Well, your .dwg has content spread out over a huge area. I see Adam is writing so I’ll leave it to him.

Yeah… about that CAD file. Wow, what a hot mess. Try this…
MASTERPLAN.dwg (418.7 KB)

1 Like

If I open that file in trimble connect DWG viewer and zoom to fit

There are elements so far away from your masterplan that your masterplan has beocome a tiny spec.

If I import into SketchUp you can see the exact same thing

Your DWG is 5318miles diagonally

If you remove those peripheral things it will work ok.

To try and do it inside sketchup - if you use the option “preserve drawing origin”

This will place your main diagram nearer to the drawing axis - if you can select just your main diagram.
copy it.

select all and delete

paste in place.

That should hopefully retain the stuff you are interested in and make it workable


What I saw too Adam. Deleted all that stuff around plan and purged the dwg to 418k. Came in 2022 with no issues. Well there was a Z issue on a few items but easy to fix in SU.


Thank you so much guys!

Didn’t realize I have made a huge mess on the file. I can import it up on the SU using the file provided by Sean.

1 Like

Good luck prabish! Glad it was of some help.

Hello Im sharanya. I’m having the same problem also. I don’t know how to make it right. I’m using SketchUp pro2021. I have attached the SketchUp file. Please help me out.


Hi Sharanya, yes, you have some “Z” issues from bad CAD usage. You can clean this up a few ways, in a dwg editor (CAD program), use a flatten plugin. move/delete the offending Z items in SU or move to a flat 2D top view in SU and export out a 2D dwg file and then reinsert back into SU.
I’d clean up the file in a dwg editor myself. There is a lot of information in the dwg file that you don’t need in SU.

key plan v17.skp (1019.3 KB)

Thank you very much for your help. You saved my day. I’m just a beginner. So I couldn’t understand the steps. Will this problem will solve if I uninstall the CAD and install a different version?

1 Like

Uninstall CAD, why? Did you draw this dwg? There’s nothing wrong with the CAD program that did this file, it’s just operator error. :wink:

Edit: typo

Ohhh I see
I didn’t draw this drawing. I thought this problem happen because of my CAD.

1 Like

Hey, something similar happening with my model here. The CAD file version is lower in comparison to my skp and a flattened dwg is of no use to me as I need to generate the contoured terrain model in sketchup, when I zoom extents, I can see no other unwanted elements, just my contour dwg, yet the import has failed multiple times. Any help would be great please!
Thanks in advance.
contour to import.dwg (389.5 KB)

PFA: The file I’m trying to import

Huh, got me stumped. It opens just fine in Acad and even in FormZ Free but SU just refuses to import it. I’ve saved it to dxf, moved it to 0,0,0 in Acad to move it closer to origin, flattened it and so far nothing. Might be something easy that I’m missing :frowning:

SKP model: contour to import.skp (278.7 KB)

1 Like

Convert all 3D polylines and then you’ll be able to import the DWG

1 Like

And there it is, very simple and I just overlooked it. Thanks Mihai :slight_smile:

Thank you so much, Mihai! Lifesaver stuff :slight_smile: