"Some imported geometry is extremely far from the model origin" error while trying to import .dwg file

Hi All,

I’m trying to import one of the file to .dwg file to SU but keeps getting the following error.

Warning:

Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

Layers:		154
Blocks:		56
3d Faces:		2175
Arcs:		484
Circles:		50
Ellipses:		5
Inserts:		725
Lines:		2660
2d Poly-lines:	595
2d Solids:		2
Splines:		4

AutoCAD Entities Simplified:

Coords out of range:	16927

AutoCAD Entities Ignored:

AttDefs:			1
Leaders:			3
M-Texts:			28
Anonymous Blocks:		206
Zombies and Others:	9

Tried on different PCs with different versions but I keep getting the same error.

Can someone please guide through the solution for the issue?

Cheers!

What version of SketchUp are you actually using? Your profile says you are using 2021 Free (web). The free web version doesn’t have .dwg import capability.

If you are using SketchUp Pro, have you unticked the box for Preserve Origin in the import options. Otr have you tried fixing the .dwg file? Sharing the .dwg file would help us help you.

Please update your profile with the correct information.

Hi Dave,

Sorry about that. Might have mistakenly selected the wrong version there.

The attached file is the .dwg file that I’m trying to import to the SU.
MASTERPLAN.dwg (3.1 MB)

Well, your .dwg has content spread out over a huge area. I see Adam is writing so I’ll leave it to him.

Yeah… about that CAD file. Wow, what a hot mess. Try this…
MASTERPLAN.dwg (418.7 KB)

1 Like

If I open that file in trimble connect DWG viewer and zoom to fit

There are elements so far away from your masterplan that your masterplan has beocome a tiny spec.
image

If I import into SketchUp you can see the exact same thing

Your DWG is 5318miles diagonally

If you remove those peripheral things it will work ok.

To try and do it inside sketchup - if you use the option “preserve drawing origin”

This will place your main diagram nearer to the drawing axis - if you can select just your main diagram.
copy it.

select all and delete

paste in place.

That should hopefully retain the stuff you are interested in and make it workable

2 Likes

What I saw too Adam. Deleted all that stuff around plan and purged the dwg to 418k. Came in 2022 with no issues. Well there was a Z issue on a few items but easy to fix in SU.

2 Likes

Thank you so much guys!

Didn’t realize I have made a huge mess on the file. I can import it up on the SU using the file provided by Sean.

1 Like

Good luck prabish! Glad it was of some help.