Import dwg into sketchup

dwg
import
3d

#1

I know there are already many topics on this: but I feel I’ve tried them all, and ala to no avail.

I need to import a 3D dwg-file.
(extra info on the file): It’s completely in 3D, I believe it was a 3ds file first that was exported to dwg. However,autocad tells me it originates from autocad or something)

I exploded the drawing, later cut it into multiple drawings because it was too big to explode further. Then I exploded till autocad said it could not explode anymore, purged, audited, purged, and saved as an autocad 2000 dwg file

I imported that file into sketchup, This time no import failed, no entities (besides one empty block) were ignored. So I was happy when I saw that import Results window. But the sketchup drawing remained empty…, nothing in outliner, nothing on the screen.

so I did an _aecacadexport, did an _autocadexport and tried again, that didn’t solve the issue. This is the Import Results window I keep getting

Please, I’ve been trying for full days now, and this is getting very very urgent. I don’t know what to do anymore.


#2

Can you attach the .dwg so one of us can check it.


#3

This is one little piece, I can’t post the original one, it is confidential.ACAD-ACAD-Drawing145.dwg (2.2 MB)


#4

Check the Options on the import dialog. I set it to meters and get this.


#5

OMG!! I don’t know yet how to find the import dialog (it doesn’t automatically show up?) , but hat I’m sure I can find!! Thank you!!!


#6

The dialog where you choose the file to import.
Look to the bottom right and you’ll see another button saying Options.


#7

It’s working! Thank you so much, how dumb of me.


#8

I’m curious what this thing is, and what it’s actual size is? Is box’s image the real size of this?

I ask because my dxf import extension had trouble importing it and I need to make some tweaks. Knowing it’s real size will help.