Importing .DWG into Sketchup

Whenever I try to import my dwg into Sketchup, I get the following warning and the dwg imports as a single line on the blue axis. I’ve found many previous people on this forum with the same issue, but none of the solutions I’ve tried have seemed to change anything. I moved the drawing to 0,0,0, I purged everything purgeable, when I use zoom to extents it only shows the drawing I need, I tried removing blocks, I copy and pasted the drawing into a new file, and I tried removing the contour lines to see if that was causing the issue. Some relevant information is that the contours are from ArcGIS and I used the export lines to a dwg tool and whenever I open the file it says something along the lines of “warning: AutoCAD didn’t create this file, do you still wanna open it?” Here’s the dwg if anyone can figure out what the issue is. Thanks!!!
aswancontours no elevation.dwg (290.9 KB)


Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

Layers:		11
Blocks:		2
Arcs:		35
Circles:		6
Inserts:		5
Lines:		203
2d Poly-lines:	314

AutoCAD Entities Simplified:

Coords out of range:	165

AutoCAD Entities Ignored:

Anonymous Blocks:		2
Zombies and Others:	1

SKP model (2D plan) :arrow_right: ter-02.skp (889.0 KB)

:exclamation: check the scale/units :exclamation:

Thank you! Were you able to just import it or did you have to do something to solve the issue?

You’re welcome!
I imported the dwg file and then with Fredo Scale I flattened the geometry to 0 on Z.


Cool @mihai.s I didn’t know FredoScale, which I use a lot, would allow that. Very handy!