Warning after importing a DWG file

I’m using SketchUp 2019
I’m trying to import a 2D DWG file, but after importing I get the following warning:

Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

After importing (ignoring the warning) the drawing seems ok to me, but it’s clear, from the warning, that there’s something extremely far the origin that could cause some problems…
Later, I extruded a 3D drawing from this 2D DWG file.
It seemed ok but, after saving and reopening it, I could see that faces disappeared, and only edges remained.

I think that a possible cause could be that warning after importing the DWG…

For the importing step I used these options:

Is there anyone who could help me?

This is the DWG file:
b.dwg (43.0 KB)

Yes. That warning is telling you something you shouldn’t ignore. The geometry is indeed a long way from the origin. (over 50 Km or 31 miles.)

The first thing you should do after you import the file is move the geometry to the origin. Select the component, get the Move tool and grab a corner. Start moving it and type [0,0,0] including the square brackets (use a semicolon if that is the correct separator) and hit Enter. Then click on Zoom Extents to show the geometry again.

@DaveR I imported with “preserve drawing origin” turned off as the OP showed, and that same corner loads at 0,0,0 as expected but I still got that warning. I wonder if one of the ignored elements is the culprit? If so, it would seem a bug for an ignored item to trigger the warning!

Might be.

I looked at it in DWG TrueView and found nothing outside the lines that form the plan, even after turning on and thawing all the layers. I think that I have seen the warning with other files too, for no apparent reason. It might be that the importer works by first preserving the origin and then moving the result…
Using the “preserve drawing origin” option places the lines at the coordinates @DaveR shows, so @rainbow has probably imported with the option turned on.

The image he posted of the options shows not.

I will chime in here because I often import DWGs and get the same warning pretty much regardless.

I used to use Autocad as my regular CAD software. When you are drawing up buildings, it is very unlikely that you would start somewhere far from the origin. I guess if you upload something like a map, you may cause a locational problem because certain systems may relate everything back to a universal point, such as the centrepoint of Alpha Centauri.

I don’t know how SU determines what the origin point should be for an imported DWG but could it be the algorithm that does that that creates frequent weirdnesses?

Our Finnish map coordinates start at the equator so they tend to stay on the planet.

I may have been exaggerating slightly but if you imported a drawing of a building with its origin at the equator, that might give problems in SU.

Thank you all.

For now, I solved by making a “Purge” of the DWG file, before exporting it by Autocad.

I still get the warning (after importing the “.dwg” into SketchUp) but now (once drew, saved and reopened the “.skp” file) the “.skp” file shows both edges and faces.