DXF/DWG Import has stopped working in 2018 SketchUp Pro

I have used my version of 2018 SketchUp Pro to import dxf/dwg files without trouble for a long time. Sometime a couple months ago dxf/dwg import just stopped working - there is no error message, just nothing happens when I try to import a file. Occasionally after a failed import attempt the shortcuts also stop working, and I need to restart the program to get them back (though changing my mouse settings somewhat helped and this doesn’t happen so often anymore). I have reinstalled the program and it did not help.

I assume this is due to some Windows update, but I was wondering if anyone had similar issues and, if so, what they may have done to address them. The only reason our company paid for Pro was for this feature and we are currently working on a project where I cannot really work around this.

Thank you!

hello, did you change your autocad version in the meantime ?

Try saving your .dwg file in an older version from autocad before you import it in sketchup. Latest versions won’t work ! I’ve personnaly set the saving to 2010 version by default.

what shortcuts are we talking about ?

No, my AutoCAD hasn’t changed. I’ve tried several versions of dwg/dxf and the same thing happens with every file - SketchUp just isn’t responding.

When the issue started all the keyboard commands would stop working, but for some reason changing my mouse settings seems to have fixed this, or maybe some other Windows update? But the import still is consistently non functioning.

how big is the dwg you are trying to import ? at some point sketchup needs quite a time before it actually shows it is importing the file. I mean, before the progress bar appears.

It will not import even the smallest files - for example, I just drew a flat 4" diameter circle in autocad, saved it as a 2004 dwg, and tried to import it, and sketchup does nothing - no progress bar or error message.

hmmm… it’s getting more and more obscur… could it be a problem with where you save the file, somewhere sketchup couldn’t have access ? like a password protected network drive, etc.

Yeah it is definitely a frustrating problem…I saved that circle on the Desktop. And again I used this feature of the program for months with huge files and no issue at all.

do you mind sending me a dwg that you are trying to import and that fails ? I’ll check on my side

sure, where should I send it?

if it doesn’t exceed 5 mb you should be able to drop it inside the reply window

Drawing1.dwg (2.1 MB)

2.1 mb for a circle, there’s something weird for a start

AutoCAD Entities Imported:

Layers:		10
Circles:		1

AutoCAD Entities Simplified:

AutoCAD Entities Ignored:

Anonymous Blocks:		4

what are the 4 blocks…

same happens here, i mean it works, but 4 anonymous blocks are ignored

Our default autocad file has title blocks of text on the layout page, so I guess those are bundled in the file but hidden since they’re only related to an exported pdf? But again I used the same autocad with the same title blocks for a good part of last year and nothing was an issue.

i’m afraid I won’t be of any further help on this matter… Works fine here. but you should precise your windows version to others

imports fine here, are you sure it didnt import…did you zoom extents

Yes, I am sure that it is not imported.

testDrawing2.dwg (19.8 KB)

try this

Do you get this window on the import?


If you do, after clicking “close” go over to the Outliner. The imported DWG should show there as a Component. Provided it does show, right click the Component in the Outliner and select “zoom selection” from the Context menu.

I have a feeling GMT may be onto something with the zoom thing. If the zoom is set too far in/out in your template then you just might not be seeing it.

Report back with any findings from the above…