Importing DXF/DWG into SketchUp Shop

Possibly posting in the wrong category as there seems to not be one for this product specifically. I’m brand new to this version of SketchUp and rusty in the application…used a desktop version 5-6 years ago.

I design in CorelDRAW daily and wish to use what I draw there as faces/edges in this web-based subscription version. I’ve been in a loop of exporting/importing/inserting much of the morning…the thing will show up in the outliner but nothing appears in the work space…yes, I zoom way out and spin all around.

I’ve run the files out of Illustrator with the same results. I’ve read about prepping the file for import pertianing to desktop SketchUp, not much at all about how this works specifically in the Shop version.

Any insight appreciated…thank you.

Shannon

delts.skp (158.2 KB) USSF Service Patch PVC_d.dwg (47.6 KB) USSF Service Patch PVC_d.dxf (164.5 KB)

Can you share the DWG or DXF file you are trying to import, and if possible, the .skp file you have attempted to import them into?

That will make it easier to help you.

delts.skp (158.2 KB) USSF Service Patch PVC_d.dwg (47.6 KB) USSF Service Patch PVC_d.dxf (164.5 KB)

Thanks!

The imported edges are only 4mm across. Do these steps:

Zoom Extents. That will be enough for you to just see the object.
Press S, or choose the Scale tool.
Drag one of the hard to see scale handles, by any amount.
Type 1000 and then press Enter.

You will now have a version that is 4 meters across.

When you do more imports, in the Configure dialog turn off the preserve origin option, and change the units to be something other than Model Units.

Thank you, that worked…sort of. Lines were very smooth and simple on export, import trashed them badly…pretty much unusable: delts (1).skp (190.5 KB)

Try this one. Better, still a bit of clean up needed.

Space force.skp (130.4 KB)

Yes, thanks…how you do that?

When configuring the .DWG import in Pro there is an option to set the units before importing. I set the units to Meters, I’m not sure if Shop has the same dialogue option when importing ( I don’t have access to Shop). There are still some off vector lines which I don’t see in the original .DWG, I can’t tell if these are due to artifacts in the dwg or part of the import process which sometimes happens, but it does not look like too much work to fix.

EDIT: Here is another version with internal faces created, just because I have an extension to do it quick and it can be a pain to do individually on SU-Shop. Good Luck.

Space force (faces).skp (165.0 KB)

1 Like

These are the import options to try with the web version (the ‘m’ units gives you meters):

Note that you can more quickly import things by dragging them from your desktop straight onto the browser window.

2 Likes

Followed those steps and the outcome was much better, thank you all so much!

1 Like

I found that the cause of no visible contents was a severe case of clipping. The patches are located a large distance from the model origin compared to their small size. As a result, from many viewing directions they are not only too small to see well but also behind the camera’s clipping plane. The steps above get them to a more sensible position and size, after which they are visible.

I followed a different but in the end equivalent route to end up with this: