.dwg defies all methods of creating faces


#1

Can someone please tell me what I’m doing wrong with this .dwg file when trying to make faces?
I added anchor points in illustrator to get some nice curves on this image and then exported as a .dwg. When I import this into sketchup, it completely ignores the “make faces” plug in and also won’t let me create faces by drawing on some of the edges. I also tried placing it on an already drawn 2d face and then tried drawing more lines and erasing the extras… this failed as well.

Is there any hope in making faces with this file? Would trying the other cad file extension make any difference?

I’ve attached the file if anyone wants to laugh at what I did wrong.

waveswithanchorpoints.dwg (63.1 KB)


#2

Dude, it’s too small. This is yet another manifestation of SU’s size limitation for very small objects: faces won’t form if their smallest dimension is about 1mm or less.

Here, I have scaled it up by 100, and the faces formed with alacrity.

-Gully


#3

And don’t forget it is grouped so you must be in edit mode.


#4

Oh, I’m sorry guys. I made another rookie mistake and simply forgot to check the size. Thank you for taking a look at it. One reason is when I imported it, and the object I was working on looked smaller… I thought it was because my import was so big, but I think it just placed it way above the other.

I should have remembered Dave and you guys did say scale everything up and then you can always scale down later. Appreciate the lesson, once again.

thanks.


#5

When things disappear or fail to make an appearance at all, it’s the first thing to suspect.


#6

The import units question was the first one I asked on the then @Last forums, and I had to blush as the thing had been hiding under my nose all the time:



SketchUp doesn’t automatically read the units used in a DWG file. The default unit it uses is Feet.

Anssi


#7

I see, thanks. That does help me.


#8

Hello there… not to stir the pot but the .dwg you included, I imported as you shipped it. The screen shots show it in cm, my units in cm and the length at ~210 cm. I only deleted layer1 and chose “Move contents to Default” from there just triple clicked the lower right hand corner to highlight it all. It did not come in as a group … as a single click only highlighted a single segment as in the entity box shows. Did you explode it before you included it?? Then I got push/pull to create a face by a simple rectangle, only having to clean out a few internal edges.
I was just following along and imported it just to see what it was ( or was not ) doing add got it to face up w/o scaling or editing. And in the DWG / DXF options with or w/o both selections had no difference Merging co-planer or Orienting Faces

The file is what I played with and bent one of the waves as I am guesting it is for the ring you are designing…

I am still green and learning myself and the fact it worked for me was a shock, so I question my findings. Put it this way I am right handed and delete things so much. I made X by itself the key board shortcut for delete so I pop it with you left thumb. Keeping my right hand on the mouse. I was trying to make an array of a move / copy by 12 and my Measurement Box just cleared out every time I entered it. Got really pissed after 10 minutes and finally realized WHY x no longer is recognized as a multiplier and need to use Shift+8 for the * now. I felt REALLY STUPID and glad I did not ask for help with that one… I learned to laugh at myself while enjoying the ride…Peace…

Faces.skp (541.7 KB)


#9

Thank you for that. It seemed more simple though for me to just make the .dwg bigger and then use the “make faces” plugin. Although, it’s just a habit I’ll have to develop when I import a .dwg because the file didn’t seem small to me. But as the experts are saying, it’s just easier to suspect that first.

Because I want to design Jewelry, I already use the template of meters. That way I can just scale it to mm when I’m done.

The key I guess I did wrong is the import file setting was too small.