Trimble Cart is broken: unable to purchase SketchUp Pro

Seems to be an issue in purchasing Sketchup, all options. See below.

12:30pm - Problem confirmed on Brave, Chrome, and Edge.

@colin Are you the support I’m supposed to contact? :slight_smile:

4:30pm - Problem is persisting. Anyone else experiencing this issue?

2:30am the next day - Problem still persisting.

1 Like

I wouldn’t be the right person to contact. I can check to see if people know there was a problem.

The page does take a while to load, but seems to be working at the moment.

11:00pm day 2 - Yes, it’s seems to be an issue still. But I will leave it to crank until it loads while I do other things.

Is there any chance my account has been denied access to purchase for some reason?

I tried in a private window, and although it still took a while to load, the shopping cart did load ok. Being a private window meant I wasn’t signed in, you could try the same, to rule out any issues with your account.

1 Like

12:15pm Day 2 - Works when signed out, but when I need to buy it I need to sign in, and thus I get an infinite buffer wheel like the video. It’s been loading for an hour now.

I have asked Support to look into the problem.

1 Like

Thanks @colin

6:00am day 3 - Still can’t buy SUpro :frowning:

You might want to clear caches and or history of the browser…

6:00am day 3 - Tried on multiple devices and browsers, even on the phone, clearing the cache and history = no dice.

Just tried setting up a new account to attempt to bypass, but I couldn’t get past this:

Surely it’s not just me?
If 287 people tried and failed to buy SketchUp or renew their subscription, its $100,000 Trimble isn’t getting.
If this is happening world-wide, then yikes.

FWIW, I just tried going through the process of buying SketchUp. I quickly got all the way through to the point of paying with no trouble. I don’t know what it is that’s keeping you from buying it but I kind of don’t think it’s common .

1 Like

7:30am day 3 - I’ve tried multiple accounts, multiple locations, multiple IP addresses, multiple devices, clearing the cache, multiple browsers, and nothing works.

11:30am day 3 - Just finished the prosses of attempting to purchase SketchUp in three different browsers, cache for all time cleared, in a private window. No dice. Spinning wheel of death.

There are several things that can cause this error. Our sales team can help if you contact us at
We are all at a conference this week, but we will help as quick as we can.

1 Like


Does that mean you got things sorted and are now a SketchUp Pro user?

1 Like

No it means I took his advice about contacting the sales team and am waiting to hear back on a potential fix :frowning:

Ah … It’ll be interesting to learn what is hanging this up for you. Probably turn out to be that you aren’t holding your tongue right or something. :wink: