Trouble Purchasing Sketchup?

I’m trying to make the leap and purchase Pro. But it just keeps cycling and cycling once I get to the “login” page of the cart. It’s been 3 days of this. I have attempted to contact sales support through email and chatbot repeatedly and I’m getting nothing. Any suggestions? (Already deleted cookies, obvious stuff, etc)
Thanks

Did you try another browser, as well?

3 computers, both chrome & edge. Add the purchase to my cart then I’m asked to login.
When I login I get stuck here:

I can walk away and come back 15 mins later to a cycling circle. Goes no further.

Do you use a Google sign in or Apple (instead of the yellow Trimble ID)?

I do use Google sign in. But I also tried logging in with my ID and password in an incognito tab.

Try to use the yellow Trimble ID. You might get prompted that the password isn’t correct. Trimble uses other rules for their passwords. A ‘forgot password’ procedure (via the yellow Trimble sign in) takes care of that.

Sorry if I my answer wasn’t clear: I use Google sign in. But I also tried using the Trimble login on an incognito tab. Neither has worked.
Also tried a 4th computer now. Same issue.