Website errors in authentication flow when trying to purchase SketchUp Shop/Pro

Hi, I’ve been trying to purchase SketchUp Shop for a few days now and I’ve been stuck on an authentication error.

The site fails to authenticate me as I try to work through a purchase flow. I get an infinite spinner and sometimes and “internal problem” error alert at https://ecom-prd.trimblepaas.com/cart/#/login. Here’s the console:

<REDACTED BECAUSE NEW USERS CAN ONLY PUT 2 URLS IN POSTS>
<its a 500 when I try to hit ecom-prd. /storefront-ui-api/cart-ui-app/settings/profile>

Remarks n’ oddities:

  • I’ve tried two accounts using gmail oAuth, they both have the same behavior
  • my last name is “null” when I go to manage account and I can’t change it (on one of my accounts)
  • I’ve tried Chrome/FF/IE11/Edge on Windows
  • I can reach the store if I haven’t logged in yet and hit the error once the site sends me through an auth flow (at the URL above)

The site is instructing me to “contact support”, which is a little insensitive considering your company makes it very difficult to “contact support”. I’m trying to give you guys money and you’re making it very hard!

Seeing that 500 makes me think the problem is on yall’s end, but I’m here to do whatever needed to debug this; I’m a dev by day.

Do you have an active Trimble ID?
In an incognito tab of your browser (preferably Chrome), go to www.sketchup.com and try to sign in.
Can you log in, there?

Yes, but the same error happens when I try to go through the purchase flow.

I’m also experiencing the same problem, but unfortunately, I already completed the payment and the website decided to go error on me. My account got deducted… I’m hoping you can resolve this issue quickly.