Topography problems

sketchup

#1

Hi All, ive been working on this one all night…! i downloaded a CAD file which was a load of single points, after trying several plugins i couldn’t get a surface out of it so i manually created contour lines which took ages… 1000’s of points to join :frowning: but now i hve a surface, but when i try to project the image of the lanscape on to it it becomes fragmented…? Any idea on how to fix this, ive tried the smooth tool but no luck…?

thanks all…

Tony.


#2

Can you share the SKP file so we can take a look to see exactly what you’ve got?


#3

Hi Dave, just tried to attach it to my post, but its too large.? But thanks for your reply is there another way to send it.?


#4

its 61mb
i can wetransfer it… ?


#5

It would appear you’re applying the Projected Image to a Group or Component.
Open the Group or Component for editing an apply the Projected Image directly to the Surface.

See this topic for step by step.


#6

Hi Geo,

Thank for the info… same results though… any ideas…?


#7

thats the same tutorial i used to get as far as i have… i think its a soften / smooth issue…?


#8

Upload it to Wetransfer or DropBox


#9

Thanks Dave, here’s the link…


#10

Try working in Monochrome to begin.

• When Hidden Geometry is off, are there Edges visible within the terrain?
• When you click the Select tool on the terrain, does Entity Info indicate it is a Surface entity?


#11

Ok, how do you changer the image to monochrome…?

and to answer your questions

• When Hidden Geometry is off, are there Edges visible within the terrain? NO

• When you click the Select tool on the terrain, does Entity Info indicate it is a Surface entity? YES


#12

With the Alt modifier key to ‘suck’ material in to the paintbucket.
Your texture already displays ‘projected’
Activate Paintbucket, suck up the (projected) texture.
Double click on the topo-mesh group (or right click and ‘edit group’)
Paint the mesh…


#13


topo2.zip (1.1 MB)

Is this what you’re after?


#14

Hi Mike,

im doing exactly that and i still get the fragmented issue…? that is exactly what im after thought…!


#15

Here’s the model at 3DWH

The root of your troubles … Misuse of SketchUp’s Layer system.


#16

Hi Dave…

AMAZING…!

How did you do it…?


#17

I assume that you hope for something like this ?


Here’s how I did it…
First I Purged unused items from the model using Model Info > Statistics.
I gets much smaller.
Then I also corrected issues with faces/edges on Layers other that Layer0 - the container group should use Layers to control its visibility, but its geometry should be on Layer0.
Next I selected the flat face and right-click > context-menu > Texture and ensured that it was ‘Projected’.
Next I edited the surface group and selected all, then right-click > context-menu > Smooth…
In that dialog I set it to apply to all edge types and at maximum slider value - that way it’s definitely a single unbroken surface.
Now, still in the edit, I opened the Materials Browser > Model and used the Eyedropper tool to sample the projected texture from the face outside of the group.
I then used it to paint the surface in one go.
As you can see, the surface then has a single projected texture - although of course the road bridge oddly follows the surface as it has no other option !


#18

Hi Geo,

thanks as well, the sketch up community is really coming to the rescue here…! how did i mess up the layer system…?


#19

Hi Tig,

Thank you as well for trying your best to walk me through it… ive followed all your points, but still getting the same bad result…?


#20

In SketchUp, ALL primitive geometry is created and lives on the Default Layer 0 … forever.
Your model model had several more layers.
Raw geometry was assigned to some of those other layers. Not good.

See these brief tutorials…

Layers


Components