Aerial texture mapping/projection not working

advice

#1

Hello,

I’m having trouble projecting an aerial image onto my terrain. Usually I find this straightforward, however I have a particularly large model this time and keep getting stuck.

I have successfully mapped onto the TIN, but would rather work with my quadmesh as it’s easier to manipulate and not quite as complex.

I can’t seem to make the texture unique without crashing SU, and therefore can’t resize or position. All edges are soft and smooth for the record! Sorry, file was too large to upload.

Thanks,

Tom

ps here’s a link to the file if that helps… https://drive.google.com/open?id=1eW0uzPzY2n0QnfIj5KkocaF9lfbqo-iD


#2

Perhaps you could give us some more information that would help us help you. What exactly are you trying to do? What isn’t working?

Please also complete your profile with the SketchUp version and license type along with the graphics card you have installed.


#4

Fixed, hope you guys can help now :slight_smile:


#5

So the image you’re using looks odd as it’s tiled and split - as indicated by the white lines.

I saved the image from SU and opened in Photoshop and realigned the split lines so that it’s not tiled like that. See image:

Then I reloaded the texture into SU and and aligned directly on top of the terrain mesh and made sure that the texture was set to ‘Projected’ by right clicking and selecting ‘Texture’:

Then I used the eye dropper tool to select the projected aerial texture and pasted it on the terrain. Seems to work ok. Anything I miss?


#6

Thanks so much. I’m very confused about how the tiling has happened. This seems to happen when I map onto to the quad, the original texture was still available and unaltered within my main model. Nonetheless, I was able to follow your instructions and it seems to have worked! I think I was a little confused about the order of the projection step and the alignment. Thanks so much for your help!!! Lifesaver…I’ve been messing with this for over a week.

I have another image I just tried this with, for some reason when I check project the image gets misaligned. I tried to edit/open in Photoshop, however it seems unaltered in there. Any ideas what might be causing this? I’m also trying to map a zoning map I’ve made onto the terrain to guide me…


#7

By default images that are imported into SU should start out as ‘Projected’. I’d recommend deleting and re-inserting your image again. Then align the flattened 2D image directly above your 3D terrain and exploded it to make it can be applied as a texture… Then do the eye dropper again and sample the image and paste onto terrain.

The reason it misaligns possibly has to do with the orientation or scale that the texture was prior to exploding and projecting. For example, if you exploded your image off to the side instead of directly above, then even if you move it, it may be remembering that original position and therefore “resets” itself when you change to projected. Once you get into the habit of following these steps you should rarely (I’d like to say never) have this issue again.