Thumbnails preview cannot be seen in folders

Hi All, I am new here. I am using sketchup pro 2020 in microsoft windows 10 Pro system.
The thumbnails preview of the skp files cannot be seen in the folder for a while.
Is there anyone who can help me out?
Thanks in advance

If speaking of File Explorer, hit CTRL+SHIFT+2 or click the thumbnail icon in the lower left corner of the window.

Look to the top menus in the folder.

View > Options


The Folder Options dialog opens.
There, click on the File tab.
And there, deselect … Always show icons, never thumbnails


Once more, look to the top menus in the folder.
View > Large Icons … or whatever you prefer.

Same issue.
I have 2020 pro at home and at work, at home I can see the preview, at work I cannot see the preview either. Always show icons, never thumbnails is deselected.

Thanks for your help, but the problem remains. :frowning:

Did you install SketchUp by right clicking on the downloaded installer file and selecting Run as administrator?

Hi,

My husband (and my IT support : ) could solve my problem, maybe it helps in yours.
He used and followed the instructions of this link below:
https://thegeekpage.com/fix-thumbnails-not-showing-in-onedrive-folder/

Good luck

Gabi

I’ve been dealing with this problem for years - and sometimes a few of the files would show thumbnails, but not others. Other times, thumbnails would show WITHIN sketchup (for instance, opening a folder window within the program) though not if I opened a File Explorer window outside of Sketchup. Lately, no thumbnails under any circumstance.

I tried a few of the fixes I found here and with Google searches, with no luck.

UNTIL LAST NIGHT: Following some tip I found here (I think), I opened the Windows settings dialogue box, navigated to Apps / Default Apps. scrolled down to a linky reading “default apps by file type”. From there, I scrolled down to the listing for *.skp. As I had found many times, the default app for that file extension showed the Sketchup icon. Should be working, right?

I clicked on the icon (inside Default Apps screen), which brings up a short drop down menu. I thought, maybe I should reset the connection? I chose “Look for app in Microsoft store” just out of frustration. Typed in “sketchup” and found the “Sketchup Viewer” which I loaded. I didn’t think it would work. IT DID!

All my thumbnail issues are gone! Yay!
Don’t know if this will work for others, but it fixed a many-years old issue for me.

Thanx Bro!
Worked whith 2021 version!
:ok_hand:

@dgruver3 I’m curious, did your change make SketchUp open with Viewer and not with SketchUp, though?

We’re exploring a possible bug with 2021 but also some earlier versions, where thumbnails don’t show sometimes for skp files. It will hopefully be fixed in the next version.
Try reinstalling and rebooting also, though.
The bug and another workaround is discussed in this forum post:

The underlying issue is that when Files On-Demand is enabled in the OneDrive/SharePoint client, which is normal and standard these days, the thumbnails are only pulled from file types that are supported by SharePoint’s previewers, not Windows itself.
File types supported for previewing files in OneDrive, SharePoint, and Teams

If Trimble reached out to Microsoft’s SharePoint team and worked with them to add .skp support to SPO’s previewers, this matter would be resolved for all versions of SketchUp instantly.

I requested this very thing in 2019 on Trimble’s forums:
SharePoint Online and OneDrive Support

I passed this Forum post link to our engineers. Thanks for the tip, @philips

How did this work exactly? The Windows App Store only appears to offer SketchUp Viewer for the Oculus Rift, at least in the UK it does. There is no option to install through the App Store to Windows without having that hardware connected/installed. I had to find the app by searching the Windows Store using Google as searching for ‘skp’ files within the Store itself doesn’t show the Viewer as available at all, even for the Rift. I did try installing it from the SU website but without any success as far as thumbnails go. In fact the Viewer doesn’t even show up in the list of apps when setting default apps for file types.

I have the same issue as everyone else but I also don’t get any file preview in the preview window in File Explorer. This whole issue is beginning to cause us major issues and is something that really needs addressing quickly with a bug fix/patch as soon the engineers can get to the bottom of it. Any updates on progress?

Update - I’ve tried it another way, by selecting SketchUp 2021 as the default file handler for skp files using the method Select file > Right Click > Open with > Choose another app…then locating and selecting SketchUp.exe, also tired with SketchUp Viewer. By doing this thumbnails (but still no previews) show up for all files saved using the 2020 file format or earlier. Any files saved as 2021 will not show up. I’m no software engineer but logic suggests this points towards a SU2021 installation/file type only problem. The software was installed as Administrator.

I’d add that my some of my files are held on Dropbox (locally held) and some conventionally held on the C: drive only. The issue appears to be across the board, wherever files are held.

-----------------------------------------------------------------------------------

Update 2 - Issues fixed (Thumbnail preview and Explorer file preview)

There’s another thread on here talking about the same issue. One poster suggested editing the Registry. I did this and it’s solved my issue. This was the process:

  • Uninstalled all versions of SketchUp (understood this is a pain) using Revo Uninstaller (free version) which post-uninstall scans the registry and deletes (almost) all evidence of the removed software.
  • Ran CCleaner (free version) registry checker. Found loads of issues. I selected Fix All.
  • Ran Windows Regedit and searched for anything with either .skp or sketchup and deleted those entries. All told only about 10 after running Revo Uninstaller.
  • Reinstalled SketchUp Pro 2021 (latest build) with Right Click > Run as Adminstrator.
  • Rebooted, checked File Explorer and all is well again.

The whole thing took me about 10 mins. Might seem tricky but it’s super easy. The time this will save going forward is worth the investment/hassle. Just now need to reinstall all my plugins and sort the shortcuts.

Hope this helps someone.

I use the SketchUp version 2021 pro. All suggested actions (Gabi, Geo)
I do not work, no success, Are there other possibilities or is it the version 2021?

SketchUp version 2021 pro with no thumbnails here as well.
I hope to find a solution that does not require uninstalling. I have in use 65 extensions and upgrading to v 2021 took 4 hours, to get them all in and working. The base/extension system seemed to me like a good idea in the beginning, but is… “not optimal” when you have to replug everything manually.

1 Like

I also wonder if this is connected? there’s been no way of loading up an SU2021 model using the context menu right clicking onto it although created on the same pc…