Old SKP files not showing in Explorer file and icon preview!

Apparently there is a KB about it;
Restoring thumbnails for SketchUp files on Windows | SketchUp Help.

with a note saying;
Note: Thumbnails should now show for any newly saved files. If you can’t see a thumbnail for an old file, you can open it and click Save and it should show the thumbnail.

For this issue - the above note is a killer – if there are 200 files in some folders - the users want to see the previews/thumbnail of the file.
One (or some) of our users are having this problem after installing a new version of SKP then uninstalling an older version. - now only new files that are placed in the folder are showing a preview.

Already tried to clear the thumbnail cache.

There must be a better solution.

A search of the forum will produce numerous threads regarding this issue.

Try installing Windows Thumbnail Preloader

https://github.com/bruhov/WinThumbsPreloader/releases/download/v1.0.1/WinThumbsPreloader-1.0.1-setup.exe

Then right click on the folder with the 200 missing thumbnails and choose “preload thumbnails recursively” this will rebuild all windows thumbnails in that folder and folders inside of that folder.

Thanks.
There are a few options.
Installing third party tools is not an option in this case (to fix thumbnail issues)

Is there an official fix for this known issue?

Your profile indicates you are using 2018. There is are no fixes for that version. If a third-party tool is not an option the only choice is a subscription to the 2022 version.

I have upgraded to latest version thanks.
Do you have a valid link for information regarding the issue in the original post of this thread?

Please edit your profile to reflect that. The correct information helps us help you.

Did you install SketchUp 2022 correctly by right clicking on the downloaded installer and choosing Run as administrator? That should install the required .dll file for the thumbnails.