This model failed file integrity checks and cannot be fixed

I’m facing this error all of sudden “This model failed file integrity checks and cannot be fixed”. How to fix it? All my work got wasted. I just bought Sketchup 2023.

Are you talking about Solid Inspector?

no just a sketchup file. I have seen this error first time

So, you’re getting the error when you try to open the file in SketchUp, correct?

yes.
Error comes like this.
“this model failed file integrity checks and cannot be fixed”

Have you tried opening the SKB version of the file?

Unfortunately this file with error is not creating skb files.

Could you share the file here, please? Maybe someone here could have better luck in getting it stable.

I’ll see what I can do.
In the meantime, here’s another forum post for the same issue you’re having. I can't open my skp file Please Help
It seems @colin was able to get his team to work some miracles, but we’ll try different options.

Great. Thank you so much for your response.

Welp, I tried opening it and got “failed to open file” before the program crashed and created a bugsplat report. Then I tried bringing it into Trimble connect to see if I could convert it into a different format and import it back into SketchUp that way. I’m sorry to say I got the exact same result.

If you have it published to Trimble Connect, you could go there and into your version history to see if there’s an earlier state of the project you can open.


Otherwise, we’ll just have to wait and see what Colin and the team might be able to come up with, see if they can make lightning strike twice.

is it possible through trimble connect to undo the few steps? because all my work is wasted then :frowning:

If you had been publishing your model to your Trimble Connect stirage you might have older versions in History and might be able to go back to one of them. Your profile doesn’t have the correct answer to the Operating System question but presumably it is Windows. Look for the backup file with the .skp. The backup will have the extension .skb. Maybe you can rename it to .skp and open it.

Where have you been saving the file? On your internal drive or to some location outside of the computer?

on my desktop. That’s the problem. This file and versions of this file all are having this issue and they didnt created their .skb files. Rest of my sketchup files are working fine and are creating .skb files.

So you haven’t been publishing it to your Trimble Connect storage, too? Then there’s no way Trimble Connect will have any history of the file.

Do you have Create Backup turned off in Preferences>General?

At this point you can hope that @colin has some success but if the model is critical it is probably worth getting started on redoing it while you wait. Very often when Colin is able to recover anything it is just the In Model components and materials. If that’s what he gets in your file you would at least be able to copy them into your new version of the model.

1 Like

Honestly I have tried every single thing which was mentioned in this thread. I can’t explain in words that what exactly this stupid software is doing. It’s not even creating .skb files. If I save it as or even copy it to new file its not opening again. rest of the files are working fine.

I’m just trying to help you. I don’t get paid to do this. I’m volunteering my time. Why can’t you answer my questions?

2 Likes

EDIT : Jean posted on the other thread, but deleted it then, So I suppose he’ll repost it here. it was basically to copy elements from the problematic model, it it’s still open on your computer, and put them in a separate brand new file. But I guess if you’r locked out of your file, it won’t help.

At this point, it seems like a corrupted file. and unless Colin can work his magic, I don’t see a way to get in this file.

This is a community forum, you’ll get quick answers for 90% of the issues people have. that’s why the help page of SU links here.

but again, if you want someone from the SU official team to have a look, you need to contact them here.
https://help.sketchup.com/en/contact-support/technical-question/form

Last time I wrote here I got an answer a couple hours later. Keep in mind they are in Boulder, Colorado (unless remote?), so they’ll probably won’t answer outside of standard opening hours there. Right now it’s 9.20 and the days is starting.

So far as I know, this is the first time this particular error has been reported on the forum. So please understand that this is not a normal or common issue with SketchUp. Is this for every file, or just for one specific file?

Also please understand that it is not likely that any of us on the forum can answer your question. We are just a community of volunteers, not an official support site. But members of the SketchUp team do (on no fixed schedule) browse the forum and take on deeper issues. Perhaps @colin can bring this to the attention of an appropriate developer on the SketchUp team.

The error you are seeing indicates that the internal database in which SketchUp captures the model has somehow become corrupted in a way that can’t be repaired. That should never happen, so clearly you have somehow tripped a serious bug. Can you describe what you had done in building the model, including such things as whether you imported models from some other source or ran extensions? That may help the developers try to track down what has happened - though frankly I don’t have much hope.

Not an answer to your original issue, but a detail that is relevant to some of the posts: SketchUp creates a backup file when three things are true: 1) you have previously saved the file, 2) you have since edited it and are saving it again to the same folder with the same file name, and 3) you have not turned off “create backup” in SketchUp settings. When saving the model, SketchUp detects the previous file and renames it to .skb before writing the new version. If it is the first time you are saving the file, this is impossible as there is no prior file. There is no incremental history created unless you are using Trimble Connect, but even then saving the file is what triggers a history save. Saving the step-by-step history for every file would be impractical.

2 Likes