PLEASE HELP! This model failed file integrity checks and cannot be opened

Hello! Please help! I keep getting the message “This model failed file integrity checks and cannot be opened.” What do I do? I cannot open an important file I have been working on for months. I have Sketchup Pro through Windows 11. I have tried to open this file on my desktop and laptop and neither work.

If you share it we might be able to help you out.

Presumably you are using Windows as the operating system? ‘2024’ does not identify an operating system. (Please correct that.)

Have you tried renaming the .skb backup file to .skp and opening it?

Where have you been saving the file while you’ve been working on it?

Thank you, yes Windows 11. Unfortunately the file is too large to upload here.

I’m not sure how to save it as a .skp How do I go about that? The .skb files want to save as illustrator files.

I have been saving it on a USB drive.

Please put that in your forum profile.

Upload it to Drop Box or We Transfer and share the link.

Right click on the .skb file and choose Rename. Give it a different name and change the b to a p.

A lot of users have had corrupted files because of that. Best practice is to have the file saved to the internal drive on the computer and, if you need to, copy it to the USB drive. If you need it to be portable, save it to your Trimble Connect storage in addition to saving it on the internal drive.

Okay thank you! Here is the link to drop box.

I see. I will start doing that. Thank you.

The file fails for me, too. It might be that @colin can manage to get something but I would suggest trying to get the .skb backup file opened as I described.

I’m able to chance the name/title of the file to end with .skp but I’m having trouble changing the actual file type.

It looks to me as if you don’t have file extensions displayed in File Explorer. Turn on file extensions so you can edit that. Or just upload that file to Drop Box and share it.

Ah thank you. I was able to rename as an .skp file. Still unable to open the file now. I’ll add it to the drop box and reshare. Are you able to open it?

Sorry. No luck. But maybe Colin will have luck with it if he can’t get the original open.

Thanks for trying!

1 Like

I could only recover components and materials. The scene itself is empty. Maybe you can get something of use out of the Components tray.

2 Likes