There was a problem downloading this file. It may have been deleted from Trimble Connect

I see that others have had this issue in the past and within the last two weeks, it’s become a big one for me.

Solutions seem to range from “just wait” to “clear your cache” to “change your project locale”. I’ve tried all these things and thought I had it nailed last night when I changed my project ownership setting. Models opened fine and I thought I was back in business. Today, I’m facing the same issue. The models are clearly there in the Trimble file system and they even open in Trimble Viewer. Activity doesn’t show that files have been removed or deleted. I’m unable to open previously saved versions of the model in Sketchup.

FWIW, I’m using Sketchup Free with Trimble Connect in Chrome on a Mac.

Has anyone been able to overcome this bug?

If you go to can you select and download the file?

Surely can.

I’m hoping to avoid having to download and upload them every time I want to work on something. That defeats the purpose (of being forced to use Trimble Connect in the first place) and robs me of the “safety net” of autosave.

I’m using Trimble Connect Sync also and all my files appear to be in the sync location. Just not sure what’s up with the file system in the web interface.

I’m wondering if it’s a file size issue. Do you regularly purge unused components and materials from the file? Perhaps you could try opening the file you’ve downloaded to your computer, cleaning it up, and then resaving it to Trimble Connect.

Could you share the file so we can take a look and see if there’s anything odd about it?

Just one of many that will not open.

wood-storage-cart.skp (262.9 KB)

I don’t see anything wrong with that one, anyway.

If you open it from your local computer and then save it to your Connect storage, can you open it from there, then?

What browser are you using?

Using Chrome. Tried in Safari as well. No joy.

I tried “Open From Device” just now and…nothing.

I click the button, specify the file and I’m returned to the file gallery. Sketchup doesn’t even attempt to open it.

Hmmm… I can open SketchUp in Chrome with no problem. This is after I opened it from my computer and saved it to my Trimble Connect account.

Is Chrome up to date?

Although he’s not supposed to be working today, maybe @colin has some ideas.

I tried Safari and Chrome, and both worked ok. Not sure what setting it would be, but I wonder if you have security settings that are preventing uploads of files?

Browser settings haven’t seemed to impact uploads to other sites/services.

Wouldn’t hurt to try changing them, though, to see if there’s any change.

I’m pretty diligent about keeping Chrome up to date. Whenever I see the green “update” button, I click it. That said, no update button was present. I went to Settings to check my version and Chrome updated itself to the version shown here:

Screen Shot 2022-01-22 at 12.44.52 PM

Which settings, specifically?

Since the original project in Trimble Connect was created in 2018, I thought that some subsequent update may have screwed up folder permissions or something. I created a new project, uploaded a couple of files to it and still get the same error.

I’m at a bit of a loss to understand what’s going on here.

One thing I wondered about, are you trying to view the models in Trimble Connect’s viewer? Even that works for me, but my initial test was on with the Open from device button in the Home Screen.

My Chrome is the same version as yours.

I just tried opening your model with the Trimble Connect option in the Home screen. That also worked.

If you check the project details in Trimble Connect, what does it say about the size in the overview?

Screen Shot 2022-01-22 at 3.25.30 PM

That doesn’t look like it’s has reached the 10Gb size limit for personal usage.
Do you have another email address which you could add to the team, perhaps?
See if that one runs into any issues might clear things.

I added a member to the team and it did not solve the issue. Still getting the “There was a problem downloading this file. It may have been deleted from Trimble Connect.” message.

Notable this time (as has happened in the past with my account), the model loads, I get the error message and as soon as I attempt an operation (zoom, orbit, etc.), the model disappears. Sketchup stops working - I select “Home” from the Open Model/Preferences menu and it doesn’t go home. I have to reload the browser window and I’m dumped back out into the project gallery.

I just tried the following:

  • disabled the one extension that’s common to Safari and Chrome on my Mac (1Password) and attempted to to load a model in Safari using the newly added team member. No luck.
  • opened an incognito window in Chrome on the Mac and attempted to open a model. No luck.
  • Moved to a Windows machine, opened an incognito window in Chrome and attempted to load a model. No luck.
  • moving models to a new folder and opening from that location. No luck.
  • creating a new folder and uploading a model file to it. No luck.
  • opened some other model files which have not been opened in some time. Mixed results.

UPDATE: I tried creating a new account that was not tied to my Google account, but that didn’t work either. I switched back to my Google account and instead of trying to open the model by navigating Trimble Connect via Sketchup, I navigated to the file in Trimble Connect, selected it and clicked “Open in Sketchup”. I don’t want to jinx it, but so far, it’s working!

UPDATE to the UPDATE: Feeling good about myself and how things were going, I put in about 2 hours worth of work on a model, saving as I went along. I encountered a save error and now I can’t open any version (up to v60 in the file history) of it. Sketchup is now telling me that “This does not appear to be a Sketchup model!”

This whole experience is making me sick to my stomach. I never had issues with the free version of Sketchup for Mac and I was able to save everything locally. Now, I have no guarantee that my files aren’t being corrupted, causing me to lose lots of time and effort.

Not sure if the project size in the details encounts for all the versions of each model that is published.
(You might inadvertently taken up the sizelimit for free of 10Gb)
I suggest you contact to inform if anything is wrong with the account.