Sketchup Free (Web) not saving, now cannot open, tried via Trimble connect and local file. Help, please!

Hi, first time user for a home project. The last version of my model did not save. It currently shows as below:
image
When clicking on it and attempting to open, it states ‘This does not appear to be a SketchUp model!’

I have tried saving the file using Trimble connect and opening that way, but it states ‘It looks like your model has not been converted into Connect Viewer format. If this is a Sketchup file(.skp) , please use the ‘SketchUp’ viewer button to view the file.’

I downloaded a version to my hard drive, but when opening it, it states ‘File not found or invalid’.

I had some pop up boxes suggesting it might be a problem at Sketchup’s end?

Is there a way to recover it, many hours spent on it, so hope so.

Others have also reported this… @Mark

Thanks, Jack. Investigating this issue now…

Hi @Sundip,

Are you having this problem with other models? If not, it’s possible your model might have been corrupted in some way. If you’re willing to attach the file that won’t open, our team would be curious. You can also send me a private message if you prefer.

Depending on how many revisions of your model there are, you might be able to revert to a clean version of the file. In Trimble Connect, navigate to the original file that didn’t save. Then follow my instructions in this forum post to download revisions of your file. You can try opening those in SketchUp, and I expect (hope!) that one of your most recent revisions will load successfully.

Hope this helps,

Mark

Hi, thanks for getting back to me. I have tried attaching the file in a private message, but it says it is too big. 17MB, is there another way to get the file to you?

Upload the file to Dropbox and share the link.

1 Like