"Failed to save file" for all of my models starting last week

I’ve been using Sketchup Free (for Web) for many months and haven’t run into any problems, until last week when I started getting “Failed to save file” for everything, even older models that were working fine the last time I saved them.

Today I upgraded to Sketchup Shop hoping that would help but it hasn’t.

I’ve read through some related posts in this forum. Some were about the location the file is saved - I don’t know where to see that and presumably that is not relevant to the web version.

I can’t download any of these models either (same error).

Interestingly, when I load Sketchup for Web, I can open any model but can’t save. Once I hit this error, when I try to open other models, I get an error along the lines of “this doesn’t appears to be a sketchup model”.

I can create a new simple model and it will save just fine.

My models (which are really just different versions of the same model) are around 36MB according to the site.

Any ideas?

I tried purging unused components and Sketchup crashed. I did submit a report as prompted.

Things are worse today - now none of my models will open at all: “This does not appear to be a SketchUp model!”

If you upload a model that you can’t open, maybe someone here can give you an answer.

Sure I would be happy to. How do I go about doing that? I know you can generally open in the web, then download locally and re-upload here or to dropbox or something, but I can’t even open to get to the download option. And when I could open these models yesterday, it wouldn’t let me download anyway.

Is there a way to give others access to a model that I can’t open?

Go to connect.trimble.com and sign in there.
search for the model, check the checkbox on front, and then choose download icon on the right.

Ok, thanks. I wasn’t aware of this UI. It turns out I can again open the models from that UI (but still can’t save them once I made a small edit).

Anyway, here is one model on OneDrive. I hope this link works - first time sharing to the world like this: https://1drv.ms/u/s!Akufev_nSJXXgSyj36LaQ7_n4iEg?e=n4bVh6

The file is 36MB so I assume I can’t just upload to the forum.

UPDATE: I started to get some errors from Chrome itself about being out of memory, so I switched to a work computer with more memory and tried there. I was able to purge unused components and materials and got the model to be much much smaller. And now I can open on my laptop again. So for now, problem solved.

I’m a little surprised that client-side resources might keep the file from being saved on the server, but oh well. I’m back in business.

Does it mean that if the model gets too big you cannot purge it because of lack of computer memory? I also have the “Failed to save file” and try tu purge the components, but it doesn’t help.

The model is about 110MB big.

Also the Download option causes “Failed to save file” message and it creates a 0kBfile in Downloads.

I cleaned up the file you sent me via a PM. Reduced the file size by about 75%. You had a lot of “heavy” plants in the model which I removed. You should replace them with much simpler plants. There’s still some excessively detailed elements such as the pillows on the couch. I left those but they aren’t helping your model.

This topic was automatically closed after 91 days. New replies are no longer allowed.