"Failed to save file" - no way to save my model

My model does not want to save. When saving it says every time: “Failed to save file”. The same hapens if I try to download the model to my computer to the .skp file. My last working .skp file is 256MB big. I tried to purge the components and materials, but it did not help.

I am a high school student and model a house for a students’ competition.

Is the model too big? Or what can I do to contnue my work and save it?

I have had the same problem and lost hours of work.
Try this:
Down load the .skp file to your computer BBUUTT select 2020, 2019 or older. This seems to work.
Saving to 2021 gives you the ‘failed to save…’ as you have observed.
Then at your next session you have to ‘import’ the model again, but at least you have saved your work.
(this problem has just happened again to me today).
Let’s hope they fix this soon.

I’m having the same problem. Just started today. I purged unused components. Didn’t help. User since 2003 but I’m using the web version now. Strangest thing. Ive tried saving as something else. doesn’t let me. I am in danger of losing a few hours of work. Well, actually, I already lost it. I tried Safari and it didn’t save. So I tried Firefox, which crashes, and Chrome, which won’t save either. I refuse to try Edge. Call me grumpy. Strange but when I close it and then navigate to it, it says it was modified today. But when I open it, it is definitely not modified.

i’ve the same problem

As @daver said, please don’t post twice.