SketchUp Web (Free) failing to save file

I’ve been using SketchUp Web (free version) for a few weeks now, just to play around with it and do some basic home design. It was working fine until recently, when it suddenly decided to constantly fail to save my model. Every time I tried to manually save or it tried to automatically save, it throws a “Failed to save file” pop-up. This only started happening within the past few days.

Could model size be causing the issue? My project is only ~100MB large, so I didn’t think it should’ve affected the saving process. I also wondered if it was due to some very recent updates with the web app.

Any help would be appreciated. I would hate to put hours and hours into a model that I can no longer work on because it will never save again! Thank you.

Yes it could be the issue.

That’s a pretty large file. Try purging unused components and materials.

“Only!” I always like to tell that a competition entry I made for a 5000 m² building ended up as an about 8 MB model.

1 Like

Wow! Anssi, you’re definitely right. My model was definitely unnecessarily big. All I’ve been making is a ~1000ft² basement with some furniture in it.

I discovered that, while I did purge unused materials, I never purged unused components! I always wrongly assumed that when I removed a component that I got from the 3D Warehouse, it got unloaded from my project. This also explains why there were still unused materials even after purging, because they still were used on those unused components.

After clearing components and re-purging materials, my model went from 100MB to 13MB! Not as good as a 8MB model, but it’s finally able to save properly again. Thank you!

Did you purge unused materials again after purging the unused materials?

I suggested to you to purge unused components and unused materials in that order on purpose.