The subscription server response is invalid

I am trying to open files in my iMac and I keep getting an error message that says “The subscription server response is invalid. You can continue to use SketchUp, but you will not be allowed to start a new file or open an existing file.”

I deleted the program and downloaded it again but nothing. Please help! I have a deadline and I need to resolve this ASAP

1 Like

…Sign out - Sign in…

best to quit SketchUp ([menu] File > Quit) in between


I have this issue multiple times per day as well since a few days.

Maybe best to clear caches of the browser that is set as default. Watch closely when signin in (or out) at the address in the bar, developers can get redirected to stg-servers… :wink:

I am using a regular subscription.
I have the impression it started with a SU update last week.

I have been getting the “subscription server response is invalid” message for the past week. I just cleared my Chrome cache for the last 4 weeks, shut down, reloaded Chrome and SU. I have Mac Big Sur 11.6. I am paid subscriber and have conformed that my subscription is active. Still get the “server response is invalid” message. What to do next?

Here are some more details about this problem with “subscription server response is invalid”. If I exit SU (btw, the most recent updated version 21.1.331) by clicking Quit SU and reload, I get the initial screen with various templates and Recent Files displayed. If I click on one of my recent files, it will open and can be edited, but the other Recent Files will get the error message. If I Quit SU, reload again, and choose a different Recent File, it will be editable but error messages for any other file. ???
Hope the gurus out there can help.

I get the same error on a Mac, with the new 2021 Sketchup Pro. Frustrating!! I’ve found that I can open one Sketchup or Layout file at a time, I get the error when I try to open a second file.

Help anyone? Any suggestions?

1 Like

This is a known issue that is being investigated. Support tell me that the work around for now is to sign out and sign in again.

none of these solutions are working for me. ugg

I also have a user with this error where logging out and even cancelling all activations does not solve the problem. She is using a Windows system, more details to follow. I have had other users over the past few weeks with this issue where logging out has resolved the problem.

1 Like


Latest version Sketchup/Layout on Windows 10

Revoking the subscription and allocating it to a new e-mail address / username has resolved the problem. Were some records corrupted during the recent server problems?

If you check the last month on you will notice some orange and red bars in the entitlement server. If you used SketchUp that time, the log files where probably affected or not properly adjusted (corrupted).
SketchUp uses those files on startup.
That’s why it is better to log out and then quit SketchUp.
(Mac users often don’t exit the program)
Or delete the log files in the appdata, you would have to sign in and have non corrupted logfiles for the next 28 days…

I just started getting the same error this evening. I am on a Mac with latest Big Sur 11.6. I updated to the latest version of SketchUp tonight Version 21.1.331. Closed Firefox and cleared everything etc. I do not know if the suggestion to delete logfiles is relevant nor how to do it. Does anyone have any other ideas???

Nevermind - The answer is in the support pages. Actually need to sign out of and back into SketchUp - this seems to have solved it.

Still getting these coming in from Mac and PC users. In most cases logging out of all things Sketchup and then back in again should solve the problem. NOTE: Not just quitting the program, selecting Help > Sign Out.

Else see my earlier message, create a new user.

Thank you. This worked for me. Very much appreciate your post !

I am having the same error over and over, super annoying and frustrating!

Hi Colin, I have signed in and out again and this does not seem to resolve the issue.