Textures, Background Colours Won't Stay

I just bought a new laptop and I’ve been busy trying to get it all set up the way I want. Last nite I got SU installed - Google SU8 and Trimble SU Make (2014) (just like on my previous two laptops - one had Windows 7, the other Windows 10). I also got my space mouse connected.

I was unable to capture the issue using the video capture that came on the laptop - which would have looked better, so I ended up recording it with my phone and uploaded it to Dropbox (file size exceeds board limit I believe). In both versions, textures/materials and the sky and background colours (no matter which style I select), “wash out,” or fade. If I use the space mouse to move around, the colours in their proper shades are displayed. But as soon as I move the regular mouse, or mouse over a tool or something, the colours blink to a faded shade. If I use the regular mouse to move something, the colours blink/flash back and forth between full, proper colour and faded colour.

Has anyone seen this before, or have any idea what would cause it… how to fix it? This is very disappointing…new pc and all.

Looks like a graphic card issue. Does your profile reflect the current graphics card? Did you update the graphics drivers directly from the manufacturer? Have you checked to see that SketchUp is being displayed by that graphics card? What are the settings for OpenGL in SketchUp?

Yes

“I just bought a new laptop…”
I’ve never updated anything on a brand new computer except virus definitions. I will check to see if there are any recent updates.

I do not know what this means, what to look/check for. Sounds a bit beyond what little I know about what makes my computer tick. Can you expound some on this?

If you are referring to the setting in Window>Preferences>System Preferences>OpenGL… Current settings in Google SU8 are:

OPENGL SETTINGS
Use hardware acceleration
[ ] Use maximum texture size
Use fast feedback

CAPABILITIES
#: 94/Colors: 64 bit Color/Precision: Medium/Shadows: Yes/Anti-Alias: 4x

Dunno if this means anything, but I clikked on the DETAILS button in the System Preferences window. The OPENGL DETAILS were:
Open GL
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1650 Ti/PCIe/SSE2
GL Version: 4.6.0 NVIDIA 451.67
GLU Version: 1.2.2.0 Microsoft Corporation

Pixel Format
94, ICD, DBL, RGBA, 64 (16-16-16-16), 24, 8, 0 (0-0-0-0)

Current settings in Trimble SU Make (2014) are the same as above except there is no GLU information in the OpenGL box in OpenGL Details - just Vendor, Renderer and GL Version.

New computers are often seriously out of date, they have been sitting in storage facilities and shops until such time as you buy them, this could be months. Unless you have a specially built one. I usually spend half a day with a new computer updating it before doing anything.

1 Like

@Box, @DaveR
Graphic drivers have been updated via NVIDIA’s GeForce Experience. It made no difference in either version of SU - colours still blink/flash back and forth between full proper colour and faded/washed out colour. There have also been, I believe, three Windows updates since I got this laptop on 08 Mar.

BTW… dunno if this bit of info is helpful, but there is no issue with viewing models in 3D in the 3DWH.

Is there anything else besides the settings I provided yesterday that could be helpful in sorting this out?

@DaveR
Can you tell me what you mean by “Have you checked to see that SketchUp is being displayed by that graphics card?” Where do I look for this info? How do I determine this?

That version, I think, is already rather old. My driver, even if it, too, has been updated I don’t remember when, is version 457.something. The current driver, also for your card, is 461.72

Yes…that info I provided for @DaveR on the 10th was before I updated the drivers… and vs 461.72 is indeed the latest driver (from late Feb, 2021), which has since been installed. But it did not help the issue.

So…the crickets have become deafening. I’ve run across some more info that I need opinions on because I’m running out of time. If it becomes undoubtedly clear that this laptop will NOT be suitable for working with SU, I have only 10 more days left during which I can return it.

I followed a link in the thread “Recommended laptop for SketchUp in 2019,” but the only info I could find that [possibly] comes closest to what may be applicable fell under “SketchUp Pro - System Requirements.”

If these recommendations are applicable to my use…then I have perhaps identified one issue…an issue I never expected in light of the fact that this new laptop is a “gaming” machine, and I was advised that it would be more than adequate for drawing and creating work with multiple layers. This so-called gaming machine does not have hard drive accelerator. I gave this no thought since RAM on this laptop can be increased and it has an NVIDIA graphics card (the reasons I chose it over other considerations) - was mistaken in thinking that more RAM would/could make up for that?

Can anyone advise whether or not the recomendations for SU Pro are applicable for Google SU-8 and Trimble SU-Make 2014, and that that one issue is in fact what the problem is as highlighted in the video linked in my OP?

NOTE: This may also be helpful – I took a dive off a technical cliff and removed the checkmark by Use hardware acceleration (since this laptop doesn’t have hardware acceleration) in OpenGL Settings thinking that would improve the situation…instead, it limited use of my space mouse to zooming in and out only.

Just saw this because of the link you posted to one of my posts (that had a link to the Requirements page.) Sometimes it takes a few days for members to see new topics. Not everyone peruses the forum every day.

You correctly found where. The OpenGL settings. The Details popup shows what GPU SketchUp is using in the Renderer field. The GL version shows what that GPU’s driver version is.

If SketchUp had been using an integrated GPU the Renderer would have given somethin like
“Intel UHD Graphics 630”

With a good dedicated Nvidia GPU like you have, you want SketchUp to have the acceleration handled by such a GPU.

Your Nvidia GPU comes with dedicated 6GB of VRAM. This is separate from the computer main memory. More main memory is always a good thing.

Re the drive accelerator, I don’t know. You might look into adding a solid state drive if your machine has an open drive bay. (But I do not think this or main memory is likely the problem with the color fading.)

I’ve not had a problem, even with very old integrated legacy GPUs, and certainly not with my dedicated GTX 1060. (ADD: I’ve always run 32bit True Color modes.)

However, the last time I saw a user having such an issue here in the forums, it was related to the Sun/Shadow settings I think. I also think it was Dave that instructed the user how to reset the sun/Shadow settings in their template to “factory defaults”.


There were some changes to how Sketchup uses the OpenGL library post version 2014.

I suggest testing SketchUp Make 2017 at the very least on this new system.
You might even take Sketchup Pro 2021 for a trial 30 day spin.

Note that this issue thread was for the Web edition, and the SketchUp Team would like to know if anyone still has this issue with the web editions.

@SketchrUppr I’d suggest testing the web Free edition and see if the same behavior happens.

I just noticed you are wanting SketchUp to use 64bit color ?
I think this may be a bit much. Try choosing one of the 32bit color modes.

1 Like

Thank you @DanRathbun for all your input. I’ve tried to answer/address some of your questions and recommendations. My apologies in advance for yet another lengthy post…

If I’m reading the specs correctly, the hard drive in this laptop is solid state. Do you mean a solid state hard drive would be better, or that I should literally add another (if possible)?

I checked it out and the web version of SU is not displaying this washed out/under saturated problem. Would that be an indication that it is not a graphics card issue in [some of] the desktop versions?

I did not set these…I never have - I didn’t know any about these settings two days ago… :laughing: That said, I checked to see what what the Capabilities were on G-SU8 and T-SU2014 on my other laptop:
G-SU8 is:
#: 265/ Colors: 128 bit Co/ Precision: High /Shadows: Yes / Anti-Alias: 0x
T-SU2014 is:
#: 265/ Colors: 128 bit Co/ Precision: High /Shadows: Yes / Anti-Alias: 4x
NOTE: That laptop did not have an actual graphics card, and I’m assuming it does have hardware acceleration. Processor is AMD A12-9700P Radeon R7, 10 Compute Cores 4C+6G, 2.50 GHz, 12.0GB RAM

This evening, I uninstalled SU8 and 2014 from the new laptop, then reinstalled them, and also installed SU 2017 as you suggested. I installed 2017 first, then 2014 and 8, in that order.

T-SU Make 2017:
There is nothing listed under CAPABILITIES
NOTE: Background & sky and materials & textures are not washed out
T-SU Make 2014:
There is no 32bit colour choice, and no 128bit colour choice like on the other laptop.
Available:
20 / True Color / Medium / Yes / 0X
36 / True Color / Medium / Yes / 2x
52 / True Color / Medium / Yes / 4x
94 / 64bit color/ Medium / Yes / 0x
Background & sky and materials & textures still washed out
G-SU 8:
There is no 32bit colour choice, and no 128bit colour choice like on the other laptop.
Available: Same as T-SU 2014
Background & sky and materials & textures still washed out

Last night, with the help of posts I found by @Anssi, and after updating the graphics drivers, I found my way into the NVIDIA Experience control panel and did away with auto-selected defaults:
Manage 3D Settings >> Global Settings >> Preferred Graphics Processor: (changed to) High-performance NVIDIA processor
Manage 3D Settings >> Global Settings >> Settings >> OpenGL rendering GPU: (changed to) GeForce GTX 1650 Ti
Manage 3D Settings >> Program Settings >> Select a program to customize: Trimble SketchUp (Trimble SketchUp)
Manage 3D Settings >> Program Settings >> Select the preferred graphics processor for this program: (changed to) High-performance NVIDIA processor
Manage 3D Settings >> Program Settings >> Specify the settings for this program >> OpenGL rendering GPU: (changed to) GeForce GTX 1650 Ti

Now…since doing that, the only thing I can do in any of the three desk top applications with my space mouse is to zoom in and out. This is the same that happened when I removed the checkmark yesterday from Use hardware acceleration (prior to making the changes in the NVIDIA control panel). I regained full space mouse capability after putting the checkmark back in.

I meant better than a physical rotating drive. A solid state drive is basically a flash memory card packaged in drive enclosure with a SATA interface, so the computer sees it as if it is drive.

The access time is memory access fast because there are no heads that need to move to do the reading.

You should reinstall in older to newer order. Reason is that SketchUp’s webdialog IE browser emulation will get set back to old settings. Well, I think really all you need to do is rerun the 2017 installer and choose the repair option.

When you run any installer, right click it and choose “Run as administrator” from the popup context menu.

Sorry, I forgot. That was the release when they overhauled the video so it would automatically choose the best graphics mode. It also writes a log file when it starts up that will list the technical details. It is the same code that is in the CheckUp utility and the log file is similar (if not the same.)

SU2017 also now uses OpenGL 3.x. This is likely better for your newer hardware.

True Color == 32bit color.

Re, 64bit and 128bit color. Only professional artists are likely to use these. The average person likely cannot distinguish (with their eyes) the itty bitty increments in color that these modes allow.

Using these modes will hog more video memory, and make things run slower. You likely would not use these modes for everyday modeling. Occasionally you might switch to these modes for professional grade rendering (if you do that kind of work.)

ADD: Also I don’t think SketchUp materials can create or save colors better than 32bit. (Someone correct me if I’m wrong here about this.)

Most do not. The dedicated GPU and it’s support chips and VRAM are built on the mother board to save space. The lower grade integrated GPUs are part of the main CPU, and together are known as an APU.

1 Like

Okay. << shaking head >>

  • I uninstalled G-SU8, T-SU2014 and T-SU2017.
  • Uninstalled 3D Connexion software
  • Returned NVIDIA settings to defaults
  • Reinstalled all three SU versions, oldest to newest, using “Run as Adminstrator” for each installation
  • Changed CAPABILITIES in the OpenGL Settings in G-SU8 and T-SU2014 to 32bit colour. Background/sky and materials/textures displayed full colour after making this change
  • Reinstalled 3D Connexion software - all control returned

It appears that the only issue from the very start, despite the slightly out-dated graphics card driver(s), was the CAPABILITIES settings in the OpenGL Settings.

Thank you @DanRathbun, @Box, @Anssi, @DaveR

1 Like