Texture mapping with V-ray is wrong

Please, edit your post for a description more short and precise like: “texture mapping with V-ray is wrong”.

Your problem is UV mapping or face reversed. Show us internal images from SU.

Internal Images? what does it mean exactly? so i can post it clearly

Anme means, show an image from sketchup itself rather than the render because it looks like the geometry may be causing the problem.

So in your model Go View and click Hidden Geometry, this will show all the underlying geometry.
Then go, View/Face style/Monochrome, this will show how the faces are orientated.
Then post a screenshot of that.

@Box…i did what u told me… I have attached picture… please tell me the reason… thank you

That shows that the geometry appears to be correct so it must be related to V-ray.
I have no experience with V-ray.
You might get an answer on the v-ray forum.
You could add more info here for anyone who does have v-ray experience, such as your V-ray version and settings.

Do you imported the texture and applied on all door faces?
I think you just put the texture by Vray and not by the Su tools. There is not UV information.

Here is a video of a basic setup showing how to import an image, place the texture on face with an appropriate size and then the rendering appearance.

@Box ok. Vray version is 2.0 .
sketchup version is 2015 Pro.
Then i have used only the default settings of Vray.
I have applied vismat file to the materials using Vray material editor

@anme i have just used the vismat file to import the texture to the materials using vray material editor. was that a problem?

This is the problem.
Do you don’t told to Vray which appearance the uv mapping will be. Like i did on video above. After import the texture.

You are telling only how much glossiness or bump the texture will have.

@anme will it give realistic images as output?

Turn on “hidden lines” in SU - I think you will find that the model has surfaces as you see in the render.

The render package is trying to orientate every surface in the model along a “base line” that is defines as running form point 1 to point 2. The problem is that when the surface is split into lots of triangles, the orientation of “point 1” and “point 2” is different for each.

Some render packages overcome this by saying that every surface with the same texture has a common base line and the texture flows between them all. (Which can also be a problem for some models)

So you can either fix the geometry in the model or choose a render package that works like the second option.

@gadget2020 I have turned on the Hidden lines. it looks like normal only.

Can u name me the render package that works with second option.? since i have done everything but nothing works. thank you

Can you attach the model? I still think that the problem is with that, but I use Artlantis - it continues the textures (a pain in the butt when doing roofs and worktop grain, but you can explode and change each surface individually.)

upload the model here. I think you did not do what I said.

@anme and @gadget2020 I have attached my model here with the original file where i didnt do any modifications that u told me to do. please see the model and clarify my doubt.Door.skp (1.7 MB)

Wood_204.zip (2.1 MB)
@anme i have done what to told me. but i have many doubts in vray material editor. please see the model and let me know my mistake.

Try this one, you have reversed faces in it which I have fixed and purged the model.
Door1.skp (600.3 KB)

1 Like

@Box Thank you …will tell u after i render it…

I am getting an output as shown in the following image

I can see texture boundaries in rendered image. i have repositioned the texture and getting an image as follows

in the final image i m getting bigger grains texture but what i need for my work is small grains with continuous texture.