Sketchup 2024 / Vray texture aren't correctly display

Hello, i encounter a bug i think with vray. Maybe you can help me out.
I recently switch from sketchup 2022 to 2024 and some texture doesnt show correctly or just arent shown at all. I can see the texture in the viewport but as soon i render it, it comes out black or not shown.
Any idea of what could be my problem? Everything comes out good with 2022 but not with 2024.
I’m pretty clueless.

Most likely this is due to exposed back faces. Switch the face style to Monochrome and check to correct any reversed faces. There should only be front faces exposed.

1 Like

DaveR: Will check for that. I’m sorry if i sound dumb but where to find the Monochrome style?
My Sketchup is in french so i’m a bit. lost in translation. :wink:

I agree it could be a problem with exposed back face but any reason why i never encounter this in 2022 only in 2024 ? i mean the models are the same…

Look in the Styles panel under Face Style or the View menu>Face Style.

Different settings in different versions of Vray?


roh, monochrome ça se traduit par monochrome :slight_smile:

menu affichage / style de faces / monochrome

sinon, tu peux rajouter la barre d’outils “styles” en faisant un clic droit sur un outil (n’importe lequel) puis en choisissant style. dans ce cas, c’est le dernier cube de la barre.

quand tu as fini, tu peux reprendre “ombré avec textures”, le mode par défaut.

aussi, sur sketchup depuis quelques années, si tu appuies sur majuscule + s tu as une barre de recherche qui te permet de chercher les outils et fonctions

:uk: I frenchsplained.
darn, Dave drew quicker !


Ateliernab: Merci pour l’info :slight_smile: c’est apprécié, j’ai trouvé

Here’s the monochrome view. Personally i dont see any problem. i put the backface red. You can notice some on the picnic table ( a model made in blender) but no red on my main model…

Possible to pass the working file? I can check it for you if you’d like. As it might be the material that has lost its connection to the file(?) like when you put the bitmap but when u change sketchup year it could have disrupted the file path.

1 Like

Looks fine, maybe it’s the material.

Sharing your file might allow someone to see a thing you don’t,
also, what happens if you make a simple cube and covers its faces with the problematic material ?

I created a we transfer so you can pick up the file here.
It’s supposed to be good till the 18 april

Thanks for your help

I don’t know if V-Ray treats transparent PNG SketchUp materials as totally transparent, but when I chose the endgrain material in the V-Ray asset editor, vlicked on the “Edit in V-ray” button and unchecked the box beside the Opacity slider, the log ends appeared in the render.

1 Like

:grinning:This problem is because your transparent channel map is lost, causing the transparent channel material to be lost. This causes the texture to become transparent directly. Please watch the video.


SketchUp materials have no opacity channel but they support transparency in PNG images. This info doesn’t seem to carry over to V-Ray automatically.
@dbordeleau , you could report this to Chaos so they could perhaps fix it in a new release of V-Ray.

His vray map path is missing, and the material may be a very old version of VRAY. It’s not a problem with Sketchup. It’s a problem with Vray’s material repair system. :grinning: