Vray rendering bug

Hello everyone,

Recently I have a problem with Vray textures on Sketchup.
I use Vray 6.0
The changes I make in Sketchup, rotation, scale, don’t show up in the render.
All my faces are well oriented.
This only happens with textures from the cosmos library but not with mine.
On the right are those that I import and on the left that of Cosmos.

If anyone has an idea of the problem, I thank him in advance.

Things to try:

Check you don’t have a material set to any groups that exist - only to the faces

Check your faces aren’t reversed .

Stop interactive rendering and start it again - sometimes the changes you’ve made don’t pass through to V-Ray.

Maybe you could save your example and attach it here, we can see if the same thing happens to us.

Merci pour votre réponse

-I don’t have any materials defined for groups.

  • My faces are all on the white side.
    -I tried opening a new blank folder with the simple cubes you see on my first post and the problem persisted.
    -I stopped and then resumed rendering several times and with different textures, in different positions.

Here is a file which for me is problematic and gives this.

Vray render bug.skp (655.0 KB)

Very strange!

I did find that deleting the material from the back side helped - I then deleted the material from the material library and reimported it from cosmos.
Things seemed to be ok after that

Yes I do not understand either, yet I spent a lot of time on this software.

Unfortunately it doesn’t work, I remodeled another shelf nearby, emptied the library and reloaded the textures from cosmos, but the problem persists.
I uninstalled and reinstalled Vray but without success.

I will try uninstalling only cosmos and reinstalling it.

Your model rendered with V-Ray 5.2

Talk to the people from Chaos.

I have submitted a request to Chaos group and am awaiting their response.

I reinstalled V-Ray 5.2 and indeed it works.
Except that if I render interactively I have a systematic bugsplat.

When I get an answer from them, I’ll share it with you, if it can help anyone!

Thanks for your help


I’ve seen this as well but haven’t had the time to troubleshoot. Thanks for pointing it out. I’ll reach out to our Chaos contacts in addition to your support ticket and see who can get an answer back to this thread first as being able to rotate textures and have it reflect in V-Ray is pretty important.

1 Like

You’re probably downloading your cosmos materials to use triplanar mapping. This will override any SketchUp UV mapping. Make sure to turn that off while downloading from cosmos unless you’re texturing something soft and round-ish such as a couch.

It’s a feature, not a bug.

1 Like

You solved the problem, I hadn’t integrated this feature yet and I had to press it to try and I left it active.
It is necessary to deactivate “use triplanar mapping”, once activated it remains so.

Thanks pyroluna