Template problem


#1

Sketchup 2018 doesn’t remember updated default template - is anyone at Trimble gooing to address this?


#2

I think they release little updates in-between versions. Maybe if you reinstall, then you will get a slightly newer version.


#3

I’ve installed the latest version.


#4

I downloaded a 2nd copy of SketchUp Make and it fixed a paint bucket bug I was having where SketchUp wouldn’t remember what textures were in my palette. The window also had a smaller paint palette. Despite the small UI difference, it was the same version (SketchUp Make 2017). I suggest you at least try to download a 2nd copy to fix the problem, if you haven’t already.

Maybe it’s not a micro-update, maybe the program corrupted somehow & re-downloading fixed the problem.


#5

Thanks Forestr I’ve tried previous versions I’ve had plus downloaded the latest version and they all have the same problem.


#6

You’re welcome. Wishing you best of luck solving the problem!


#7

That is the understanding, but I have not see a maintenance release in SU2018pro, with it being mid September already and their annual release is more-or-less at the end of November (traditionally, so don’t quote me on this) I think it is highly unlikely that there will be a maintenance release before the next version.


#8

Julian - they are selling a faulty program!! They need to fix it.
I’ve been using Sketchup Pro professionally since the original @last version. The program has been f**ked around by Google and now by Trimble.
It’s time these keyboard jockies who play around with the program realised their responsibility to their customers.


#9

In SketchUp Make 2017, the program remembers which template I chose last session. Is anyone else experiencing @janama’s problem with SketchUp Pro 2018? Does anyone’s version of SketchUp Pro 2018 remember templates? I’m trying to figure out if it’s a problem that varies between users or if it’s a problem with every copy of SketchUp Pro 2018. Are they selling a buggy program or are we just using it wrong? I know I am using a graphics card that’s not recommended for SketchUp, so I assumed that’s why I get certain bugs or crashes. Even with the minor bugs, I prefer SketchUp over other 3D software, but to each their own. Most programs have minor bugs, so I’m not sure if the grass is greener on the other side. I’ve checked out tons of other 3D software and SketchUp is still my favorite.


#10

I have no problems in setting a default template, so unless they provide different versions, it could be something on your system/workflow…
How do you save the updated template?


#11

Same way I’ve always saved templates Mike.


#12

This has been discussed at some length in another thread and no resolution has been forthcoming. It would appear , at a guess, to be a permissions issue with your file system that is causing the problem.
As a Pro user you have access to Pro support and I would recommend you go that route now that many options have been tried here on the forum.


#13

It’s posted in the Pro section automatically Box.


#14

This is a community of volunteers/users. Not Support.

https://help.sketchup.com/de/contact/technical-support


#15

There’s a difference between saving a template and changing your default template. Saving a template will not change your default template. To change your default template, you need to go into SketchUp > Preferences > Template and change it there. From there on out, typically any new drawing will use the template in your preferences.


#16

Forestr, I’ve done all that.


#17

When you installed SketchUp did you run the installer as admin ?
If not that can produce weird effects with folder and file permissions…
Is your new template’s SKP saved where you expect it ?
In your C:/Users/YOU/AppData/ tree - your custom Templates folder is next to your Plugins folder…
It’s hidden by default…
image

You probably don’t need to uninstall/reinstall SketchUp…
Here is the only correct way to try to fix this…
Do this whilst logged in as your normal User.
Note that having admin-powers is not relevant to this, because the proper installation method ensures it’s set right anyway.
Close SketchUp if it’s open.
Find your SketchUp installer’s exe file - it’s probably in your Downloads folder ? [or download the installer again]
Select its icon and right-click > context-menu > “Run as administrator”.
Respond to any prompts…
When asked choose ‘Repair’.
Let it complete then try using SketchUp again.
Any personal Plugins etc should be safe…

Try saving a Template, set it as the default and restart SketchUp to see if it’s stuck this time…


#18

Thanks TIG - I’ve tried all that and there’s no difference. My template is stored where it should be and the template opens but it won’t remember my pluggins tools (layer manager and Housebuilder) and it won’t remember the position of my trays - I have my trays open on my laptop screen and the program on my larger second monitor. It just won’t remember their positions yet all previous versions of the program would.

I’d be happy to run with Sketchup 2017 but it won’t allow me to install it as it says my key is out of date!


#19

Note that plugins, extensions, and toolbar location are not part of the template. The toolbar locations are registry keys. Position the toolbars where you want them and then make some simple model and save it. Some users have found they need to save a file to get the registry keys written.


#20

It has always saved these factors before in the template - what has changed? It currently remembers my layer manager plugin but not the others.