Su 2016 demo is it crippled?

Hi guys, I am trialling the latest dl . I was stuck on su6-8, noting with concern how each revision dumped some nice tools and gave less functionality (together with all those nice little add ons from the community). what ever happed to “if it aint broke, don’t fix it”

anyway I am noticing little bugs appear
like selecting paint bucket/choose a colour, but the cursor doesnt switch to a paint bucket, same old arrow so you dont know your in pb.

Layers manager not working properly, can’t create layers and the tab doesnt show a layer on/off

Are there more of these annoyances?

If trimble wants to restrict the trial version, then say so up front so I dont waste my time struggling with a bug

Sounds like Trimble created this bug especially for you and it’s not a global bug…


The trial version is fully functional.

Display issues and / or odd tool behavior often stems from poor OpenGL support by the GPU and its driver.
Tell us more about your graphics processor.

1 Like

SketchUp 2016 Make and Pro both start with a 30 day trial period, during which all Pro features are available and nothing is crippled. LayOut and Style Builder are included with this trial period.

At the end of 30 days, SketchUp Pro requires a license to continue running, but SketchUp Make will continue to run but without the Pro features enabled. Note the SketchUp Make is for non-commercial use only.

If this is your first taste of a Trimble version of SketchUp, be sure to check out the Extension Warehouse, where you can easily download & install extensions to improve your workflow.

The issues that you’re seeing with layers and such don’t sound like a known issue. If you can expand on the behavior you’re seeing, perhaps we can figure out what’s wrong.


1 Like

AFAIK its an intel hd graphic 4000, memory?

using an asus essentio core i7 64bit

anything more i should find out?

previous version of su up to su8 have alway been a bit flaky on my pc and its extra wide 29" screen - doesnt like split screen, but i found work arounds mostly (never had a problem on XP)



Intel HD 4000 is notorious for inadequate OpenGL support.

1 Like

more info

1792 MB

2560 x 1080 display 32bit 59hz

I ran this

opengl viewer

and it reported test good fo 3 thru opengl4

few years ago hd4000 had probs with og3

what does su2016 use?

Hi Marc, can you tell me if su2016 - student version is limited and where i can find what the limits are. I am trying to get my students interested in 3D

I don’t know OpenGL innards enough to tell you exactly what the issues are, but there are numerous reports on this forum about SketchUp problems when using Intel integrated graphics. SketchUp is one of the only apps that makes truly deep use of OpenGL, so it hits driver and hardware bugs that others may not experience.

1 Like

Yes, SketchUp has issues with several of the Intel HD cards - 3000, 4000, and 5000. These cards advertise to the system that they obey OpenGl 3, but in practice there are some holes in their implementations. If SketchUp hits one of those holes, then you’ll see things like graphic artifacts, unexpected wire-framing, etc.

Re: student version - There’s no specific student version. I don’t know about your specific lab setup, but I would expect that you’d be running SketchUp Pro in the lab with a special discounted educational license.


Hi Marc
Ive been a true supporter of su since su4. I thought it was incredible, ground breaking (cw acad 14 still running on dos - acad didnt get comfortable with windows gui for 5 years after that)

I want to get my students to buy their own copies to take round with them, but will have to get my own first to convince them of the value

Su has such a broad user base from architecture thru 3d mold design, enginering, construction etc as evidenced by the xtensive galleries

Its so easy to pick up (cw 3dmax, maya poser etc). A student with basic drawing skills could be 50% there in 2 weeks or less.

So I want a prog that works properly without bugs as this is very discouraging to newbie students

I might have to go back to my xp desk top as i never had a problem there

Win 8.1 gives me hard time with su 6,7 and 8 various issues. I wouldnt give that to my students, makes su look mickey mouse

SU is still 3D modeling for everyone, as it always has been. For those with OpenGL deficient graphics hardware and graphics driver, disable hardware acceleration. In SU, go to Window > Preferences > OpenGL and disable Use hardware acceleration. Restart SU. Still have problems?

Post XP, you need to install SU as administrator. Did you r-click on the installer and run as administrator?

Programs require the use of OS browser to function properly - accessing the internet and supplying javascript, etc. So for Windows machines, IE needs to be updated to the latest version and maintained (med security, clear cookies and cache.)

Each version of SU use more OpenGL functions than the previous versions. So if one’s computer had iffy performance in SU6-8, it shouldn’t come as a surprize there could be performance issue with the latest SU release. Disable hardware acceleration as mentioned above.

SU has launched a version of SU that runs in a modern browser, using WebGL. It’s called my.sketchup, currently in beta. Sign up as a tester. It runs in a Chromebook, though it requires a mouse.

1 Like

Well that worked, those little bugs have gone and i get my paint bucket cursor as expected, layers behave. bit like the early days when you had to go on the forum to find out how to use the app properly but we had a great band of enthusiasts always ready to share tips.

Funny thing though, when i closed su as you said, it completely disappeared, so i didnt have to uninstall it? It now seems to have installed properly as a normal app with ogl off

But when i started it came up saying i didnt have an internet connection? cos i am connect as you see?

checked IE and im v11 and it works ok. But I could use add location from google earth but it thinks im not in IE

I did dl and instal through my prefered browser firefox, should i have dld thru IE?

I have gone to make ie my default browser, so whe i restart maybe that’ll work

same old su, tips and tricks you need to know but su doesnt tell you, but you gotta love it



have signed up to my.sketchup


You didn’t experience any bugs. When possible, SU uses OpenGL functions call supplied from a graphics driver to speed things up. But your MB’s integrated graphic chip’s graphic driver is not 100% OpenGL compliant. With hardware acceleration enabled, SU tried to use your graphic driver for required functions, but your driver was missing the necessary function calls. By disabling hardware acceleration from inside SU, the CPU is doing all the work instead of splitting the computational workload between the CPR and GPU.

By closing then reopening SU, you just cleared out the cobwebs. CPU is doing all the work (with a fully OpenGL compliant graphic card with its own dedicated graphics RAM, OpenGL calculations can be as much as 3000x more efficient than relying on CPU and motherboard installed RAM alone.)

Now on to the browser issue. Programs don’t care which browser you prefer for browsing the internet. So keep your preferred browser preference. Program are its own, unique micoinviroment. Program call upon the operating system for certain functions (SU is not alone in this, Photoshop and others do it too.) The default OS browser throws in more things than just browsing the internet when programs need a browser. Javascript is one of those other things. And it’s up to the computer user to maintain their computer, which includes the default, OS browsers - IE for Windows, Safari for Macs.

Now on to IE function in SU. You say you can get Add location to work? How about Window > Extension Warehouse and Window > 3D Warehouse? Also can you search through 3D Warehouse models from the Component dialog?