Still getting startup crash after opening 2016 Pro

crash
startup

#1

Gents, can I get one of you to look into my bugsplat crash report(s)? I’d like a diagnosis to begin meaningful troubleshooting. Been happening for several months (and different version of video drivers). Tried reinstalling twice, no difference.

Layout starts and works just fine.

Win 10 Pro
i7 3930
32 G Ram
SSD drive
GeForce GTX 780Ti running drivers released 3/28 (v364.72)


#2

I found 3: they’re all Ruby-related. Disable your extensions and it’s likely you’ll be good. Update them and add back in to find the culprit.


#3

Barry, you are hard core for doing this on a Saturday and I’ll give that a shot in another hour or two. Thanks a ton for looking into this.


#4

Barry, I gave it a try and no joy. Since I can’t start the program the only way I know to turn ruby extensions off is to remove them from their normal file system location.

C:\Users\JWiley\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins\

I am able to do so but when I start SU Pro 2016 they are all repopulated and the startup continues to fail in the same way. Can you provide some concise method for me to remove these from outside of the execution environment? If it takes registry hacking, invisible files, etc. bring it on!


#5

You should also check and disable extensions in the “extensions for all users” location:

C:\ProgramData\SketchUp\SketchUp 2016\SketchUp\Plugins

#6

Jim, thanks for the tip but I don’t have anything in that path. The …\Sketchup folder is empty, no “\plugins” there


#7

you can start SU from the command line with

path to SketchUp.exe + /DisableRubyAPI

or on a mac path inside app contents + -DisableRubyAPI YES

might help find the issue…

john


#8

John! You star! Using this command line switch paved the way to starting SU and I can even do stuff without it crashing! Now I can get into the program settings and turn off the ruby extensions the “right way”.

Thanks John, well done!


#9

tick as solved and we’re even…

glad it helped…

john


#10

Hi John

I am new to SketchUp. SU crashes every time I click Start using SketchUp. Do you have any advise to get over that hurdle? I do appreciate your feedback.


#11

@abrieleroux

See this pinned post for SketchUp 2017 Issues:

(1) Update your Intel graphics driver (links in the pinned post above)

(2) Update to SketchUp 17.2 (if you already have, please update your forum profile.)


#12

Hi Dan

No joy yet.

I am in the process of upgrading to 17.2, but requires serial number. During one of many attempts to get SU to work I opted to tick the box to not see the “home page”. It is on this page I am suppose to click “Start using SketchUp” It is on the same page I am suppose to click the Licence to view the serial number required to upgrade. Do you know how to get hold of the serial number now?


#13

Help menu -> Welcome to SketchUp


#14

Hi

When I click on the SU shortcut in the start menu, it takes me straight to the drawing frame and immediately thereafter crashes. How else can I access the Help Menu?


#15

Do you mean a license ?

If you have already licensed SU2017, then information is already in your lic file.
And the installer doing the upgrade would just use the current lic file.

If you had not licensed SU2017 (ie, … as the trial period has expired,) and you have purchased and received a SU2017 license, (and as you say cannot reach the Welcome dialog,) then it is best if you contact Customer Support directly, and open a support ticket on this issue.
https://help.sketchup.com/en/contact/technical-support

They will ask you what extensions (plugins) you have installed and whether you’ve run the Checkup utility and created a .sulog file. (They’ll want to see that log file, and you can attach it here.)
Get the Checkup utility here: https://help.sketchup.com/en/article/3000318


#16

Thank you Dan for the advise. I’ll keep on trying.


#17

Hi Dan

Can you make something of the attached file?

SketchUpLog.sulog (75.8 KB)


#18

Yes, it gives your driver version as: 20.19.15.4531. This was a beta version, that had two successive beta drops afterward. An then 30-Mar-2017, a general release of version 4624.

To get the latest, go here and scroll down to the downloads list:

Other than this, the Checkup log shows all other requirements are met.


The other thing you can do is check the Windows logs for application errors running SketchUp.
Start Menu > All Programs > Administrative Tools > Event Viewer