SU2018 Crashes on Startup - how do I unload extensions or perform a clean install?


#1

History:
I’ve been having problems with SU2017 Pro crashing on startup. If I try to open a new model I will crash 3 out of 4 times, so I could eventually open it.
I unloaded a lot of extensions but that didn’t help. I also tried different Nvidia drivers, also without success.
Then I gave up and installed SU2018 Pro.

At first SU2018 worked fine, but as I began adding extensions, at some point the startup crash occured. I think the culprit was Fredotools because an error message once briefly flashed up about the wrong version of FredoLib.
A few extensions I loaded were having issues updating or obtaining a license.

Now SU2018 crashes instantly, every single time on startup, so I’m unable to access the extension manager to disable any extensions.
I re-downloaded SU2018 Pro and installed (ran as administrator) and did a clean install of new Nvidia drivers, ran all windows updates, etc, without success.

I’ve submitted numerous bug splats but I don’t see any content in the report (the button is greyed out).

Is there something I can try next?

Thanks


#2

A few errors from the Windows event viewer:

The description for Event ID 1 from source BugSplat cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

su18win
SketchUp
14745

The program SketchUp.exe version 18.0.16975.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 9a0
Start Time: 01d38804e1b5f4e2
Termination Time: 31
Application Path: C:\Program Files\SketchUp\SketchUp 2018\SketchUp.exe
Report Id: d340bbc3-e1cd-4d59-9271-1d1faefdd927
Faulting package full name:
Faulting package-relative application ID:


#3

rename your Plugins folder then restart SU…

SU will make a new folder with the ‘default’ su ones…

re add the others one at a time…

john


#4

Thanks John

I tried renaming the Plugins and the Components folders located here:
C:\Users\xzy\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp

and also this folder
C:\Program Files\SketchUp\SketchUp 2018\ShippedExtensions

This didn’t fix the issue. I’m not seeing any new fodlers that were created by SketchUp. I’ll now run the installer again and see what happens.


#5

leave ‘ShippedExtensions’ as they won’t be re-installed and SU will not run correctly…

it’s only 3rd party ones you need to block…

john


#6

Thanks again John.
I repaired the install and it works now…! :star_struck:

…now to figure out which of my 100+ extensions is the culprit! :sob:
Is it safe to install extensions that are marked “incompatible”?? (i have about 30 of these)


#7

It depends on whether they are truly incompatible, or just not yet certified by the author for SU 2018.

If they ran in 2016 or 2017 they will probably work in 2018, I think (others on the forum will know definitely). I don’t remember reading here about any changes in Ruby from 2.0 to 2.2 that will break earlier code, unlike the change from Ruby 1.8 to 2.0 some years ago.

A quicker way than adding 100 extensions one at a time is to do in effect a binary search.

If you have renamed your Plugins folder to Plugins - disabled (or similar) so SU doesn’t load any of them except the SU supplied ones that get reinstalled automatically into Plugins, then add half at a time from Plugins - disabled to Plugins and restart SU.

If it crashes, delete the half you just added, then copy the other half into Plugins. One easy way to keep track is to split them alphabetically at a first letter, or first two letters.

If that works, than add half of the remainder and restart again.

If it crashes again, remove from Plugins half of those you most recently added, and try again.

Repeat until you find which plugin or plugins are triggering the crash.

And leave out the plugins that aren’t clearly marked as Compatible, until you’ve sorted out the rest.

Then add them half at a time, as before.


#8

Ok that’s great… I didnt realise Installing an extension was as simple as moving an RBZ into the Plugins folder. :slight_smile:


#9

Not quite - most extensions nowadays have both a plugin-name.rb file AND a folder called the same plugin-name.

You need to copy both.


#10

And .RBZ shouldn’t be in the plugin folder.


#11

how did you repaired the install? My sketchup last 2 days does not work … SketchUp not responding


#12

I manually removed all my extensions by moving the Plugins folder. That prevented exensions loading, which solved the crash.


#13

Thank you for your response. Appreciate your help.


#14

UPDATE - The Extension that was causing me problems is FredoLib (Fredo Tools Library). I’ve tried 3 versions of the extension including the latest (8.0c)

I notice the extension has the following name (with strange characters in it)

Fredo6_!LibFredo6.rb

Could somebody else test this on 2018 Pro?? (I’m on windows 10 and SU 18.0.16975)


#15

remove fredo’s .rb fro your post please…

add a link to an official source instead…

Fredo’s extensions, require a restart before they function…

john


#16

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.