Sketchup Pro 2018 Crashing after clicking Start Using Sketchup

crash
bug
sketchuppro

#1

I have Sketchup Pro 2018 installed on Windows 10, 64-bit.

I installed 2017 last winter and had no problems with it. I upgraded to 2018 shortly after it was released and experienced a couple minor bugs. Now, however, Sketchup will load the start screen but crash shortly after clicking the “Start Using Sketchup” button. This happens regardless of whether I try to open the application empty or open a Sketchup file.

Any help would be greatly appreciated. My Pro support just ran out a couple weeks ago, and I need to get some drawings out to a client ASAP.

Thanks,
Chris


#2

any error messages?

the 3 common reasons are:

1.) incompatible graphics card driver, i.e. OpenGL support not compliant => update
2.) incompatible plugins/extensions => udpate/disable
3.) Win: wrong or missing prerequisites (= MS runtime libraries) => install SU again by “r-click > Run as Admin” or install the libs manually one by one (point #5).


#3

Sketchup 2017 is functioning fine on my computer, I discovered. I would really like to get 2018 up and running, however.

How might I go about disabling my plugins if I can’t get the application to load in the first place?


#4

you can start SU from the command line with a \DisableRubyAPI flag…

or rename the Plugins folder…

there are threads explaining both methods here somewhere…

john


#5

Just reinstalled it. Lost all my extensions, but it is working again.

Thanks for the help!


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.