SU2017 install not going well


#1

I have had to reinstall Win10 and now when i download and install SU2017 I have gremlins. At first i had a “missing mfc140u.dll” file missing. I corrected that by downloading from microsoft the appropriate files and that issue does not pop up anymore. However, now on the install it sats it can’t find the appropriate “msi” installer. I downloaded the newest version of the installer from Sketchup.com , rebooted and tried the install. I says i have an older version of SU2017 that it can’t remove? It shows i my control panel/programs, but i am not able to uninstall it from there. Seem to be missing some files to accomplish that. Any suggestions on what ails my PC regarding this install. It was all working fine last week before the crash. I restored from a ISO image and now you know the rest of the story. Thank you in advance.


#2

We you ran the installer, did you right click on it and choose Run as administrator?


#3

If you have downloaded the latest v2017 installer from the main source you should have an exe installer file.
Find that [in your Downloads folder ?] and select it, right-click > context-menu > “Run as administrator”

This is the only correct way to install an app in Win10…

Dang! @DaveR beat me to it !


#4

I am in administrator mode asit is the only account i have setup.
I hope these screen shots will shed some light.

thank you for the quick response


#5

But did you right-click and select “Run as Administrator”? It is not sufficient merely to be logged in as an Administrator user.


#6

I did right click but the option to Run as Admin is not in the menu


#7

Are you running in some sort of virtual setup? I ask because in the lower left corner, it has your remote credentials.


#8

No, No…that is the access credentials to my savings account…:open_mouth:…i am not in virtual mode. thx


#9

Ah! In that case, since you are likely not seeing the “Run as administrator” when you right click the installer, you likely don’t have administrator rights on your computer. Can you get admin rights, or do you have a system admin that can run the installer for you?


#10

this is where it gets fuzzy. I am the Administrator for this laptop


#11

Being the administrator for the laptop is not the same as the point we are trying to get across. The right click thing is something else, a Windows thing.

Using Windows File Explorer locate the Sketchup.exe file. (probably in your downloads folder) Right click on the file. Run as Administrator should be the second item on the context list. Left click on that item.


#12

I thank the forum for their patience in working thru this. I probably should try to be a little clearer with the steps i take. I have Uninstalled SU2017 and rebooted the laptop; I am signed in as the “Admin” for my laptop; I have done a fresh download of SU2017 from the Sketchup .com website. I have “right clicked” on the exe file in my downloads section; there is no run as administrator in the menu as I too would expect. I understand what you are saying as I use this method to install other programs. It just is not there, not even greyed out. So I run the file by double clicking and it seems to go through the install process without any issues. It is when i try to open the program that i get the popup that says you need mfc140u.dll to be installed and it asks for a path to the file ( which i do not have). I have downloaded from microsoft.com the package visual studio 2015 redistributable that contains that particular file and have installed the package, however, if if look under windows/system32 there is no file labeled mfc140u.dll. there is a file called mfc100.dll and several other dll’s of that type. There is one other thing, there appears to be another program called Sketchup2017 i Control Panel/Programs that i am not able to uninstall. I do get a popup after uninstalling the current version that says there is another version of SU2017 that can’t be uninstalled. Does this sound like maybe a registry issue? thank you for all your help.


#13

OK. I did a Google search, two thing I noticed among others. Are there any language packs installed? Is the UAC working? Check to see if the information on the link applies.
http://www.top-password.com/blog/fix-task-manager-is-disabled-or-greyed-out-in-windows-10/


#14

You’ve probably already done this, but I would recommend changing your password now :wink:


#15

Yeah, thanks Marc. I did . I had to laugh at myself when i realized that was in my screenshot.We’re only as secure as the knucklehead at the keyboard.:rolling_eyes:


#16

The UAC and Task Manager are both working. I did try another avenue with some luck. I installed a prior version of SU2016 i still had and instead of validating the license i went directly to the Upgrade button, which brought me to the download section of SU. I then downloaded the 2017 version and at that point, when i right clicked I did get a “Run as Administrator” menu item which i initiated. The download process seemed to go just fine without a hitch. But opening the program gave me a pop up that said mfc140u.dll was missing and asked for the correct path to the file SketchUP2017-x64.msi installer? Does this sound more like a Win10 problem. I have downloaded and installed the Visual C++ 2015 Redistibutable Package previously.


#17

If you make a copy of the installer’s exe file and re-suffix it as a .ZIP file you can then extract the contents into a folder.
The longed for .MSI file is in there…
I suppose you could try running that ??


#18

Well after a Google search I see that the Autocad people have the same issue. So I looked to see what C++ version I have. They are versions 4 of them from 2008, 2 from 2010, 4 again from 2012, 2 from 2013 and 2 from 2015. The following link is from the Autocad forum:
Autocad forumhttps://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-remove-and-reinstall-Microsoft-Visual-C-Runtime-Libraries.html
Note that on x64 systems you need both the x32 and x64 versions
Dave


#19

I just reinstalled my Windows. I already updated it to Windows 10. I did not really have any problems installing SUp 2017, until I solved the problem of opening the Advanced Camera tools, SadBox, texture photography, dynamic components and Trimble Connect. This was to be installed … My recommendation is, the next time you reinstall windows it is better that you open 2 administrator accounts. =/


#21

Regarding VC++ update, the recommendation for SU is to first manually install the latest version of VC++ if the SU installer failed to retrieve the latest VC++ update and install it. If that was not adequate, then uninstall all previous versions of VC++ on computer and then install the latest. See 2017 not launching.