Can't uninstall sketchup pro 2017

Hey,

for some reason I can’t remove\uninstall Sketchup 2017.
It is prompting that is can’t find this file:
SketchUp2017-x64.msi

Thx

Any help?

You could try downloading the installer again, run it with the Repair option, then try uninstalling again.

Not guaranteed, but it might replace the missing .msi file.

Hi John,
Thank you for your response!

I actually did that but getting the same error when it is trying to uninstall the previous version during the installation process.

This is the link to the folder:
C:\Users\XXXXXX\AppData\Local\Temp\sketchup_install\

I was thinking about installing it on another pc at home and try to copy the file but maybe someone can send me this file?!

Installation error 1

error message
Installation error 2

Try to switch off, then turn on your computer.
Do not start any program just find the Windows Control Panel\All Control Panel Items\Programs and Features and locate the SU 2017 and uninstall from there.

Thx

I installed the SU pro 2017 (not the same build) on another computer and copied the files the location it’s supposed to be and it looked like it worked but I still had that entry on the “programs”.
I forgot to say that the app is working!

I tried to install and then I had 2 SU 2017 on my “Programs” list.
I can only uninstall the new one.

I’m an IT tech so I know a lot of tricks but i’t not working.

Any help from the Tech support???

Anyone have a solution to this? Recently installed 2021 and need to remove 2020 for the extra space.