I have a problem with installation of SU2017 that I can't resolve

installer
2017
install
installation
thumbsup

#1

ThumbsUp.dll failed to register - contact support -


#2

Did you select the SketchUp installer exe icon, right-click > context-menu > Run as administrator ?
If NOT try that…


#3

nope , that didn’t work tooo


#4

The method I suggest is the ‘official way’.

Can you expand your details - OS, Graphics-Card etc…


#5

windows 7 64bit , nvidia geforce gt 520m


#6

Is your GC driver up to date ?
If not, then update it…

If that doesn’t fix it perhaps someone from SketchUp Support will chip in here…


#7

I downloaded the Sketchup 2017 program and I installed it on my computer. Meanwhile the downloading and the setup I did not receive error. It did not start when I wanted to run the program, but there was not warning signal. Nothing happened.
I uninstalled the program, I downloaded new one then and I installed it. Unfortunately, the result was same. I don’t know what’s wrong, though the SketchUp2016 runs correctly now on the computer (maybe, two sketchup versions not be installed simultaneously on same computer?)
My notebook is Toshiba Satellite L550, CPU: Intel Core i3, RAM: 4GB, Video: ATI Mobility Radeon HD 5165. The operating system is Windows7 Home Premium 64-bit, SP1. And 200 GB are the free disk spaces.
Please, help me
L. Murphy


#8

Two versions of SketchUp can definitely be installed on the same computer at the same time (many of us do so on both Windows and Mac), so that isn’t the cause of your problem.

When you ran the installer, did you right-click and choose “run as administrator” (note: that IS NOT the same as running while logged in as an administrator)? If not, give that a try. There are some obscure permissions issues that can affect SketchUp on Windows if you don’t install this way.

If you did install via RAA, then perhaps you graphics card driver isn’t adequate for SU 2017 (ATI/AMD drivers are variable in their quality of OpenGL support). Try updating it and make sure you system is set to use the ATI card for SketchUp.


#9

How did you uninstall.?
Before trying to install did you click on the properties button for the xxxx.exe.There may have been a unblock option that then appears? Did you select that before running the install?
Which version of su did you download, there are two possible, the make or the pro version. The make provides a 30 trial of Pro and the reverts to the free version. You profile indicates you have the pro version installed but I guess it is really the make.
When you remove SU the first time per you post above did you use the add remove control panel options. That control panel list may show the other programs loaded, style builder and layout which are part of the pro version.
I remove all vestiges of all files when have this type of problem suggest you try that and see it helps but of course that is you choice.


#10

I say thank you his help, it was very useful. The graphics card driver was
very old (same age with my notebook). Downloaded newest ATI driver and
updated the old, all problems ceased. Both of SketcUp versions (2016, 2017)
too worked perfectly.


#11

An old thread but seems to fit my problem. I am trying to resurrect an Acer Aspire 5517 running Windows 7 Home Premium 64 bit. Windows thinks the driver for the ATI Radeon HD 3200 Graphics card is the latest available.

I have downloaded and installed SU2017 using the ‘Run as Administrator’.

When I attempt to run Sketchup, nothing happens beyond sketchup.exe appearing the the process list of Task Manager. It is using CPU time but that is it.

When I attempt to run Layout, the ‘splash’ screen appears, then the User Agreement, and finally the ‘this is a trial version’. After that, it is the same as was the case with Sketchup.

Style Builder acts just as Sketchup.

Any thoughts or suggestions?


#12

install latest video driver available from the notenook maker… if still failing drop it.


#13

The driver version number on the Acer support site matches the version installed so I guess it’s time to give up on SU2017 on this laptop!!!


#14

try if the SU version 2016 which is less demanding concerning the required OGL support of the video driver runs… maybe by disabling the hardware acceleration (= OGL) from inside SU at “Window > Preferences > OpenGL”.


#15

Run the OpenGL viewer , this will be total check of OpenGL installed; second run freshdiagnoses http://download.cnet.com/Fresh-Diagnose/3000-2086_4-10065841.html and this will report on a number of items you have installed. Both are free apps http://realtech-vr.com/admin/glview