Can't Download / Install the Trial Version to Run (Sketchup 2017)


#1

I just downloaded Sketchup 2017 and tried to double click on the icon to launch the program. I’m using Windows 8.1, 64 bit. The program will not launch. I get the beach ball then nothing. I have Sketchup 2015 installed and it launches fine. What’s up?


#2

It’s possible that your integrated graphics don’t meet the tightened requirements for SU 2017.


#3

#4

And to cut to the chase, review SU Checkup freezes, SU2017 won’t start.

Just writing down Intel graphics in your profile doesn’t help much. Your system must support hardware acceleration to run SU17. Earlier versions of SU had the option to perform software rendering through the CPU. That has ended with SU17. We need more info to assess if your system can install a driver that includes the required OpenGL support.


#6

Yes, I know it is very frustrating if a program of which you may have had high hopes won’t run. I have had similar frustrations with other software in the past.

Rather than rant because your computer isn’t suitable for running this version of SketchUp, why not look in this forum for a link to download an older version which is not so demanding of hardware? If you search for ‘download sketchup make 2016’ you will find at least one link. The older free versions are no longer available from the sketchup .com download page.

You will get more helpful responses if you keep your temper.


#7

@usmma76 Could you post a screenshot of your system’s installed programs? I’m interested in which versions of the C++ libraries are installed.


#8


#9

Thanks, @usmma76 .

It looks like you have the correct version of the C++ redistributables installed.

Have you tried uninstalling SketchUp and re-running the installer (making sure that you right-click on the installer and selecting Run as administrator?


#10

Thanks for your help, Mark. I’ll try uninstalling Sketchup in the morning and following your directions for the reinstall, but I don’t think I have enough graphics horsepower. I have a 3 year old HP All-in-one p.c. with integrated 2500 graphics. It has a place for an MXM video card, but I don’t know if I want to try to install one because the power supply may not be large enough and I may have to rig something up to keep the processor on the graphics card cool. I’ll let you know how it goes.


#11

Mark,

I just uninstalled and reinstalled Sketchup 2017 (ran as administrator). The program still won’t run . I did the same thing for Sketchup Checkup and it does the same thing it has done in the past. The program stops running and asks me to close it (before displaying any information about issues my system may have). Thanks!

Don Michaels


#12

If you haven’t already, you could try updating the graphics card’s driver. Assuming that it’s the Intel HD Graphics 2500, drivers are available here.


#13

Better to try updating driver from computer manufacturer first than trying to install the ones at Intel site. The manufacturers may tweak the drivers to optimize them for their machines.


#14

The Intel driver won’t install. It gives an error message stating that I have to use the driver from the manufacturer (HP). See enclosed picture of the error message. That driver hasn’t been updated since 2013 (that I can find anyway). When I try to update the driver through device manager, it tells me I have the latest version. I am also including a picture of the device properties driver tab and the message I get when trying to update the driver. My p.c. doesn’t have a graphics card; it has integrated graphics. It can have a graphics card, but I would have to add it and some other stuff. Thanks for your help.


#15

Excellent suggestion.

Definitely check the computer manu’s site to see if they have a more recent driver.


#16

typically not a more recent driver because notebook manfacturer are always behind the official driver release stream but a driver customized for the hardware of the system… typically throttled for allowing a reduced power consumption and less heat devlopment which needs to be tackled by the compact cooling system of notebooks.


#17

Mark,

I uninstalled the HP graphics driver which resulted in a Microsoft generic graphics driver being installed when my system rebooted. I then installed an updated Intel graphics driver (too bad HP doesn’t keep their driver up to date). Sketchup Pro then started, but my trial version had expired without me ever getting a chance to use the program. I also ran Sketchup Checkup and it ran all the way through and said my system was good to go. Is there any way for me to get access to the Sketchup Pro trial version again?


#18

Mark,

I just ran Sketchup Make. All seems to be well except that the ESC key won’t halt a command. I have to either select another tool or select the Selection tool. Am I doing something wrong?


#19

@usmma76 Yes, contact the help folks via this link:
http://help.sketchup.com/en/contact