2017 download and install errors (outdated Intel graphics driver)

installer
opengl
installation
graphics
download

#1

Hello there, SketchUp community,

I’m a long time SketchUp user. I love the utility of the program and stand by it quite often, but I’m having a problem installing the latest version. The process seems to be stuck on a step, as a screen just hangs out with the green bar filling and progressing. Once it progresses to 100%, which should lead to the next step, the bar just falls to zero and starts all over. I let it process for about 2 hours the other night, thinking that I was just being impatient, but no luck. I installed the 2017 version on my other PC last week in about 5 minutes with no problem, so I know it’s some incompatibility with my laptop, which is curious because the laptop is the only one of the two machines that’s had a previous version. I know it works on my laptop, but am unsure of what exactly the problem is right now. Any thoughts? All info will be greatly appreciated!

The screen that loops reads:

“Installing Microsoft .NET framework 4.5.2 (x86 and x64)…”. Super informative.

Thanks,

Trace


#2

Hello Trace.

Let’s try helping the SketchUp installer by pushing it from behind. Based on your provided information, head here - Microsoft .NET Framework 4.5.2 Offline Installer, download the offline installer of NET Framework and install it yourself. Then try installing SketchUp again.

Your problem is also addressed in this article from SketchUp’s Help Center: NET Framework Error in SketchUp. (It offers the same workaround.)

Also, your page here says that you’re running on Vista. I might be wrong on this one, but if I remember correctly Vista is no longer supported for SketchUp. If it really is true, you might want to consider upgrading your OS to one of the supported versions.

Let us know how it goes.


#3

@VahePogossian You are correct–Vista is not supported for SU 2017. We require Win 7 or later for SU 2017.


#4

Thanks a ton for the helpful words, gents. I installed the suggested 4.5.2
NET Framework business. The SketchUp install seemed to go as it should. The
windows all progressed and closed, but now when I click the SketchUp icon,
nothing happens. The program looks like it’s on my desktop but it won’t
open. Also, I looked a little closer at the OS on my machine. I’m running
Windows 8, not Vista. That was the last one. Thoughts? Any help would be
greatly appreciated!

Trace


#5

(1) Ok, then it’s time to update the IT information in your forum profile.

Graphics drivers for embedded Intel GPUs can be a headache for the new version of SketchUp. It will help to know what your HD graphics model is, or the full model number for the CPU, and what your full graphics driver version is.


(2) You could see if the execute attempts are generating a Windows Error Report.
See this post:
SketchUp 2016 Crashing on Startup


#6

Probably the most cliche-ed reply - have you tried right clicking and running as Administrator?


Running Sketchup Make on Windows 8.1
#7

Haha I haven’t, but I will! Thanks.


#8

Well, Vahe, no luck with the “run as administrator” attempt. Good idea tho!

Dan, here’s the error report. Can you translate? I work with a welder and
hammer everyday, so this is all Greek to me! Any and all help will be MUCH
appreciated.


#9

@jtrace620

Have you done the standalone update to the C Runtime and been sure to install update KB2999226 per:


#10

Man, no luck! I downloaded and installed all the fixes in your forum post,
restarted, downloaded the new SketchUp again, restarted again and nothing
doing. Same story. I try to open it and I see the little Windows wheel spin
for about 2 seconds, then nothing. The install wizard even gave me a new
option during setup that I thought was promising- “repair”. I was thinking
it knew something was wrong and could see it to fix but perhaps not. The
only thing that didn’t go as planned during the fix attempts was that the
KB2999226 update, etc. just searched for files to update on my computer for
about 10 minutes. I thought that was long enough and aborted it. Should I
run it longer? Thoughts? Should I uninstall SketchUp and reinstall?

After all this, I only deal with one person that works in the 2017 version
of SketchUp. I could very easily get along in the 2016 version for
everything else. If there’s no solution for me, is there a link to the 2016
version to download from a reliable source?

Thanks again!

-Trace


#11

SketchUp Product Downloads has links to download SketchUp Pro 2016. 2017 turned out to be a bit difficult to install and run properly.


#12

You never actually posted the WER report.


#13

Uh oh. I was corresponding via responding to this string via email, which
apparently didn’t like me attaching files. Let me log into the forum and
attach it that way.


#14

Report.wer.txt (15.9 KB)

That worked a little better (seemingly). Does this compute?


#15

That update to the C Runtime MUST be installed in order to run SU2017. (You can see what updates have been installed, vai Control Panel > Programs and Features then choose “View installed updates” in the left navigation pane.

From now on, make sure you install everything (updates, applications, etc.) via a right-click “Run as administrator”.

I’ll take a look at the WER report.


Sketchup Make 2017
#16

@jtrace620, Jackson

Same ol’ story: Your Intel Graphics driver suite version
has known issues with it’s OpenGL library.

Sig[3].Name=Fault Module Name
Sig[3].Value=ig75icd64.dll
Sig[4].Name=Fault Module Version
Sig[4].Value=10.18.10.3496

As said in several threads here, users with older Intel HD integrated graphics
need to update to version 10.18.10.4061 or higher.


#17

Man. Still no luck over here. Same story on the KB- update. It “looks for
updates” ad nauseam. This time I let it cook for about an hour, with
nothing ever happening. Its little bar just spins and spins. I tried a more
manual approach to the driver update. Is there a link to the 10.18.10.4061
that I’m missing? I don’t want to just go downloading it from some
willy-nilly www.freeviruses.com and I couldn’t find a link to the .4016
file on the microsoft site. I went through my control panel’s prescribed
updating prompts also. Same story. Little bar just spins and spins forever.
“Searching for device updates online”, or something to that effect. No
dice. Spent about 2 hours trying to fix but with no success. Frustrating.

Any thoughts? I’m also willing at this point to downgrade to the 2016
version, which worked fine. Is there somewhere online to get it that’s safe
and easy? Any and all help would be much appreciated!

Cheers,

Trace


#18

If you mean SketchUp, I’ve posted a link to the main official download page of the program, some time before in this topic.

I only vaguely followed this thread, seeing as @DanRathbun helps you, so I can’t be of much help but a couple of things: Are you using a notebook? And if yes, could you tell the brand and exact model? If this is a problem, where you have to downgrade/upgrade your hardware, you should not only look in Microsoft or Intel but in your computer brand’s support download website as well. If I have the model and brand, I’ll see if I can find the necessary update for you. Asus for example lists different graphic driver updates for some of its notebooks, compared to Intel. Maybe this is a similar case. Meanwhile, if you’re eager to resume working in SketchUp, download the 2016 version, which is, at the present, more suitable and stable for you.


#19

Thank you sir. I am indeed on a laptop, an HP Envy. I bought it second
hand, so I’m not quite sure what year, probably 2014 or so. I’ve had every
model of SU since 2010 (obviously on this machine and others), but this is
the first hiccup I’ve ever experienced. I’ve made hundreds of drawings and
love it (most of the time- haha). Never realized how much I’ve grown to
rely on it until I’ve been without it for the past month or so.

Silly me, I poked all around the SU website looking for a 2016 version but
never just typed it into the browser search bar. My bad. Did I mention I
work with a hammer and welder every day and that computers aren’t really my
thing…

Thanks again for the help and enthusiastic words. I really appreciate it!

Trace


#20

Which model of HP Envy? A quick way to check the exact version for Windows 8:

• Hit the Start button and type “msinfo32” and open the program that comes up.

In here, look for the “System Model” value. Better screenshot the window and post here to avoid any misunderstandings.