Installation Problem 2017 Make


#1

I have used SketchUp for many years with no problems installing. Computer failed purchased new, running Win 10 pro. When I try to install get message during Installing Files "Model C:Program Files\Sketchup\Sketchup 2017\ThumbsUo.dll failed to register. HRESULT-2147024770. Contat your support personnel.
If I ignore message an load, message when I try to run "R\The code execution cannot proceed because VCRUNTIME140.dll was not found. Reinstalling the program may fix this problem. If I need to add a file please give clear instructions, I can use software but installing file into the operating system is beond my skills.
Thanks for any help.


#2

Windows errors are often not specific to one application. In your case you’ll see that a lot of people have had the same error, and a couple of places I’ve seen people talk about raising an issue with Microsoft. But, I didn’t yet find a Microsoft report on the issue.

Here’s one example: https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/tmtoledll-failed-to-register-hresult-2147024770/7b49344f-d883-40c5-91dd-df148047cf4b

If you search for HRESULT-2147024770 you’ll see other cases, and maybe there’s one where someone gave a good solution.


#3

One possibility: did you right-click and choose "run as administrator " for the installer? It is not enough to be logged on as an admin, you need this explicit step.


#4

Steve Thanks for the response. Cannot get to a point where I an run. Problem is the installation. Program will not install, one of the dll’s will not register. Think it is a win 10 problem and will work with tech support for the new computer.


#5

He is talking about Running the Installer! Not running the program.
Go to the downloaded .exe file from wherever you downloaded it, probably the download folder, and Right Click on That and choose Run as Administrator.


#6

Ran with administrator with same results. Believe problem is with Win 10. Since new computer will give problem to tech support.
Thanks for the help.


#7

Researched the HRESULTS and found many with same type of problem, no real solutions. New computer, turning problem over to tech support.
Thanks for the help.


#8

There have been previous reports of problems with ThumbsUp.dll.

Search the forum for this term ‘Thumbsup.dll’ without the quote marks. You should find some possible solutions.


#9

John, have researched and the more I research the more confused I get. I think it is one of the problems no one wans to take responsibility for. Install Make 2015 without problems. This versions uses the same dll’s and c++ programs as Make 2017. I give up one 2017 and will use 2015 until someone can supply a solution.


#10

Problem solved. Problem with the win 10 software originally installed (this is a new computer. After several hours with tech support, decided windows was the problem. Reinstalled and was able to download and install Sketchup 2017.
Thanks to all who provided assistance.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.