SU pro 2021 freeze

I’m new to Mac and I’m having the problem that when I’m working with a file it immediately freezes and I have to force the exit, I try everything, nothing works.
My Mac is new (2 months).
Happened to someone else?


Please upload the file so we can look at it. I doubt it is the Mac causing it to lock up.

Sorry for de delay!
Informe.pdf (4.1 MB)

I think that RLGL meant you should show us the SketchUp model file, not the system crash report.

Sorry, I’m very new to SU and Mac.
What do you mean by “model file”? Talk to me as if I were in kindergarten, I’m not going to be offended haha.
Thanks for the patience!

This file that you are working on is the “model file” - share that file here so that others can look at it and help you diagnose your problem.

The “model file” will have a .skp extension


I send you the link of google drive since it won’t let me upload it because it weighs 137mb.

At 137mb you may not be waiting long enough for it to open.

I have no problem opening it. The problem is when I am working on it it freezes.

Please change the permissions on your file so we can download it.

Also please update your forum profile. It says you are using SketchUp Free (web) but you posted in the SketchUp Pro category.

Either way, it sounds like your model is bloated and your computer is simply struggling to work with it. Freezing doesn’t mean it has crashed, it often just means the computer is working on it.

Drive File (done thanks for your notice). Im using the 30 Day Trial.

I tried several things, from waiting up to 10 minutes, and opening the “activity monitor” and seeing the CPU and memory usage, and when that happens it is at 100% capacity and it shows me as “not responding” that is why I have to force the exit.

That’s still not the free web version.

Box is correct. Your file is bloated. After correcting the incorrect tag usage…
Screenshot - 1_29_2022 , 6_21_31 PM

…and purging unused stuff from your model…
Screenshot - 1_29_2022 , 6_21_54 PM

…the file size is reduced by about 68%.

If you were to clean up your model I expect you’d find your computer is more able to handle it.

Also, you could take a little time to clean up some of the components you’ve collected from the 3D Warehouse. For example the wine cooler. It doesn’t look like your model is about the wine cooler but that is a huge part of the file size. There’s really no point in having the labels on the bottles since you can’t see them unless you press your nose against the glass. And the bottles don’t really need to have punts in their bottoms or even bottoms at all. That stuff is adds file size and makes your computer work harder while adding absolutely no benefit to your project. If you’re leaving the bottles in there you should at least correct the face orientation on the on at the top.

Also, just looking at Dave’s screenshots. I’m guessing you have Profiles turned on, the thick line around shapes, turning that off in the view menu or in the style tray will help immediately.

1 Like

He does, and also Edges turned off. With Edges turned on, Back Edges is also on.

Who does? Who is “he”?

I didn’t change the style except for the last screen shot of the bottles.

In addition to the things Dave and others said, I think the biggest performance problem in the file is the materials. This may not be all your fault, if you downloaded models from 3D Warehouse the original poster may not have taken time to optimize things.

For example, the TV picture is over 15 million pixels in size. A lot of other textures are over 2000 wide and tall across. Reducing the sizes of the materials, and purging the ones that are not being used, reduced the file from 137 MB down to 23 MB.

I believe that when Box said “I’m guessing you have Profiles turned” he meant the original poster, not you in particular. The ‘he’ I meant is mebdesignstudio.