SU Outliner 2023 seems different

I waited several months before beginning to use '23.

It’s fluky but with a Component select and then Group selecting with shift+ it usually gets it going for me. If it did not I would also switch back (still have 22 installed).

Have you closed and reopened the tray? I’ve done that a couple times when the tray seemed frozen.

My guess is that some of these changes have to do with Trimble Connect Web (Models and Layers) and maybe setting up to use TrimBim files. Dunno though.

Good luck!

Im still using 22 but obviously need to switch to 23 at some stage to stay compatible with certain plugins. Would you say 2023 is now okay for your purposes?


I’m switching over to '23.

The main way I have been using Outliner in '23 is to Group Components (so everything in the Model is a Component and they are Grouped in the Outliner as I go). If everything is tidy as I go, I have fewer problems. Here’s an example that I recently made - with a little mess but mostly nested Groups and Components… and I don’t recall a big hassle as I went.

But the issues are real. I watch to make sure things aren’t renamed (or ‘un-named’) to ‘group’. If that happens I just undo it.

I click into groups and components a lot so clicking 5 times to name Groups as I go isn’t an issue for me. I also sometimes use a double or triple button which is handy for other things anyway.

There is something to selecting the Top Level Components and then selecting Groups… so if I try to shift select and that doesn’t work I’ll select another (usually higher level) Group or Component and then shift select again (not a good explanation but you can get the ‘feel of it’ and select what you want).

*This example also has a point cloud…

I too am having this issue and it has preventing me from using SU 2023

Little reminder shot to bring up the post.
Outliner renames the groups on its own, as soon as you select non-concomitant groups in the list using the CTRL key. :rage:

I tried making an extension to help with some of these problems. The unwanted group renaming can still happen, but it is easier to name groups with a prompt since you don’t have to click a bunch of times.

I think that anyone who says is this is ‘no big deal’ is under-clubbing the issue. This is a HUGE deal, and I’m dealing with it every day. The Outliner has been one of the core navigation tools for SU from the beginning, and is a huge “click-suck” now. Does the dev team not even use this tool?
The other major issue of the renaming is also a huge issue, especially when one is building complex models that feed other models or Layout. MAJOR bug.
Inadequate new feature implementation is one thing. BREAKING something core to the workflow is another.


I’m likely an outlier, but I never use outliner!

1 Like

I agree that the quintuple click and sudden renaming to “group” of previously named groups is not so great. I created a toolbar extension to solve the problem and create a better workflow.

When components are selected, you click the “Group Namer” button. A group is created and a prompt appears with an input for the new group name. Press “enter”, done. This promotes naming groups when they are created, and side steps using the normal ‘create group’ → LMB 1 (x 3) (or 5) times in the group name field of the new group in the Outliner.

There is a link to it in the post above yours. I have not heard any feedback but it could be a work around to take the pain out the Outliner glitches.

That’s also great about SketchUp, it allows many different workflows.
I really can’t do without the Outliner. So stuck in v2022 until it gets fixed.


I’m also not using 2023 because of the changes of Outliner.


Just tested SketchUp 2023.1. Disappointing, the issue is still not fixed.
230914: also tested 23.1.319 (installer 2023-1-319-110). Same.
231011: tested 2023.1.3 (installer 2023-1-340-117). Same.


I waited to download 23 to work out the bugs but the outliner is still not working properly. Shift+click doesn’t work; can’t explode or group things directly in the outliner without clicking into whitespace and tapping spacebar, and it’s glitchy so occasionally I’m losing my selection. Also the outliner doesn’t jump to the selected element anymore. The messaging here seems to be that either the product was immature, the beta group isn’t sophisticated in how they operate the software, or the outliner is being discouraged as a tool, none of which are encouraging to contemplate.


I completely agree. If it’s not broken, dont fix it. Outliner is one of the main tools for BIG projects. I work on interior design and it is my main “go to” tool in Sketchup for organizing and turning “ON/OFF” things. Without that I’m blind.

1 Like

Think Im going back to 2022 also. 5 minutes on 2023 and it is driving me crazy. I wasn’t using it because I was still using V-Ray 5. Just bought and upgraded to V-ray 6… and I’m installing 2022 right now.

Can we get a refund for this period, I finally have to throw in the towl and use an old version, its just too awkwarda dn problematic, does anyone know if it is vray thats something to do with it, I’ll try a fresh install and see

I don’t know about that, but basically you are paying rent to use SketchUp, whichever version.

1 Like

I don’t see any of the forum user giving you an answer. and even the sketchup employees roaming around won’t, not on the forum.

you’ll have to contact them the standard way

that’s my opinion too.

If a car was this broken I would give it back rather than use a 2 year old model when I’m paying for a brand new one

1 Like

and in order to try to do that, you would go to the company that sold it to you, not to a public forum.
see my previous message. contact them and see what they tell you.