SU Make 2017 not using Hardware Acceleration


#1

Hello, I’ve been testing Sketchup for a day now to see if the performance is better than on my Girlfriends Surface Pro 4. Sadly I can’t seem to activate Hardware Acceleration even after trying all the tips and tricks from the forum.

Short Speclist:

  • i7 6700k (without dedicated GPU)
  • 32GB DDR4 RAM
  • GTX 980ti with 6GB VRAM

What I’ve tried so farm:

  • Set the 980ti as OpenGL Renderer in the NVIDIA Controlpanel
  • disabling every Plugin
  • running SketchupChecker
    https://imgur.com/aEOhIZ2
  • Unchecking "Use fast feedback
    https://imgur.com/IixYYL9
  • Older and newer nVidia drivers (currently on 398.82)
  • Updating BIOS to the newest Version
  • Using GPU-Z to see if the GPU uses the full linkspeed

The weird thing is that in the taskmanager it seems that Sketchup is using the dedicated nVidia GPU but it’s still stuttering and lagging (The same file works perfectly on my girlfriends Surface Pro4)
https://imgur.com/rLShFbX

Right now I’m pretty much at my wits end as to what to do to get SU to use the GPU for Hardware Acceleration. If more info is needed I’ll gladly provide it!


#2

Does the information in this Post Help? Surface Pro


#3

No, to clarify this is a Desktop Tower and I’m comparing it to a Surface Pro. The Surface is having no performance problems while my Desktop Tower is struggeling


#4

Looking at GPUZ with a 12MB file loaded when I use the orbit command , the core clock gets up to about 1113Mhz and the memory clock gets to 1752 Mhz. Can you play games smoothly?


#5

Yes gaming is absolutly possible, the expected result with such a card. This is also not a new PC, it ran well the last 2 years. When playing games, or any other 3D application for that matter (like AutoCAD and Fusion360) the card turbos up like expected.

In SketchUp however it doesn’t really turbo up.


#6

Try repairing the installation by right clicking on the installation file and selecting “Install as Administrator”


#7

Not all 3D applications use OpenGL so your comparison might be apples and oranges.

This does sound like you’ve possibly not installed SketchUp correctly. Try @RLGL’s suggestion making sure you are signed into the computer with your normal sign in.


#8

After Repairing as Administrator it displays the same symptoms, no switch for Hardware Acceleration. @RLGL

I’m signed in as an local Administrator Account, the PC is not joined in any domain.

And the GPU works in another OpenGL application just fine.


#9

Where are you expecting to see a switch for Hardware Acceleration?


#10

Am I mis-remembering? As I recall, the last version that had the option of turning off Hardware Acceleration was 2016! If I’m right, then your attempts to turn it off will be fruitless as there is no option to turn off Hardware acceleration.

And: Dag Nabbit! I see that @DaveR beat me to this point! Posted just as I was writing the last two words of the above paragraph!


#11

The last SketchUp version to have a “switch” for Hardware Acceleration was indeed SU2016. Turning off Hardware Acceleration in Preferences>OpenGL dumped rendering duties to the CPU and was useful for computers with feeble GPUs. There is no such option in SU2017 or later.

@DaDesasta, you might look at the power setting in the Nvidia control panel–farther down the list in your screenshot. What is it set to? Try setting it to Prefer Maximum Performance.


#12

The Energysettings were on the Global Setting, which was Maximum Power preferred. I’ve now set it to Maximum Power directly, but nothing has changed, still lagging.

Just an odd question could it be the file that’s the problem?


#13

Are your open GL settings set something like this…

2018-08-25_12-32-19


#14

Actually no they look like this, to try and get the maximum performance

sketchup6

The Energysettings I was talking about were the Nvidia Controlpanelsettings @DaveR mentioned

The settings I’ve changed here:

  • Energymanagement (Energieverwaltung): Prefer Maximum Power
  • Optimize for Power: On
  • OpenGL Card: 980ti
    sketchup7
    sketchup8
    sketchup9

#15

Did SU ever work right on the PC?


#16

Have you checked the Graphic Card Details?
Have you installed SketchUp 2018 as well?


#17

No it never worked, a fresh reinstall also didn’t prove to be successful…

@MikeWayzovski What “Graphic Card Details” are you talking about? No only SketchupMake 2017 is installed as that’s the only free sketchup version I’M aware of.


#18

Is this a store bought PC or did you build it? What happens if you put the graphics card in a different slot?


#19

check graphic card details:
details

to be sure, only checking taskmanager could be misleading.

If you had installed the (trial) version of 2018, the Nvidia could have ‘ignored’ the 2017 version.

In the beginning of this year, there were some problems with the Microsoft C++ Distributables, check the date in programs:

image

Remove 2013 and 2015 and reinstall SketchUp.


#20

The GPU is detected there:
sketchup11

No other SU Version was ever installed on this PC, other than SU Make 2017
This are my current Microsoft C++ Distributables, none of them date to yesterday where they would’ve been installed. Can I somehow see which one SU uses? (Also there are that many because games seem to be installing tons of them…

@RLGL This is a selfbuilt PC, that has seen some upgrades of the last 2 years, swapping the GPU around doesn’t help.